Tweak to trick apps requiring iOS versions

Discussion in 'Jailbreaks and iOS Hacks' started by lucifiel, Dec 19, 2010.

  1. macrumors 6502a

    lucifiel

    #1
    Hi All,

    One of the annoying aspects of JB is the inability to upgrade to the newest (not necessarily greatest) version of iOS, at least without some set back, the present version of iOS being a great example.

    Thus, I do not want to upgrade to iOS 4.2.1 and be stuck with a tethered jailbreak, but I want to download and play Dungeon Defenders (another game that runs on the Unreal Engine)...alas it requires iOS 4.2, and my current phone is on 4.1.

    I was hoping that someone could tell me if there is a tweak that will allow me 'trick' apps into thinking that I'm running on iOS4.2 without actually installing it. Though I also have a suspicion that this may not be entirely possible, but any help would be great.

    Thanks :)
     
  2. macrumors 65816

    WiiDSmoker

    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148a Safari/6533.18.5)

    Should be plausible. But it may depend on the game/app. They might make usage of certain APIs in the newest firmware.
     
  3. #3
    Chances are if an app has a minimum iOS version requirement, it's using newer API's and functions which wouldn't work and crash the app on lower OS versions.

    I'm sure the idea is possible though.
     
  4. macrumors 604

    labman

    #4
    You do know that a untethered jailbreak is do by the end of the week.
     
  5. macrumors 6502a

    lucifiel

    #5
    There's also an issue of, "i dont' want to upgrade and reconfigure". Thus, if this was a route, I'd rather take it.
     
  6. macrumors Nehalem

    Applejuiced

    #6
    Exactly.
    If it requires a certain built version then if its installed on an earlier version the app would not function. If it did they would have made it compatible.
     
  7. macrumors 6502a

    lucifiel

    #7
    ahh well, back to patience being a virtue then.
     
  8. macrumors 6502a

    jpetticrew

    #8
    I agree with this in theory, but there are several apps that require iPhone OS 3.1.3 and will not run on iPhone OS 3.1.2. I understand requiring iOS 4.0, but I don't think any new APIs were added between 3.1.2 and 3.1.3.
     
  9. macrumors 6502a

    tctony

    #9
    We both know this is not the case.

    Sometimes developers just arbitrarily only make it available on newer firmware versions.
     
  10. macrumors 68000

    ulbador

    #10
    Most of the time this happens when the developer compiles and updates the app after downloading the new XCode update. Apple makes it a royal PAIN to keep the ability to compile your app for a lower iOS version than the newest one if you aren't paying attention.

    I had a heck of a time compiling one of my apps for 3.0+ when I was running the 3.1.3 iOS SDK (and not using any specific API changes present in 3.1.3 or anything more than 3.0).

    I recently installed an AdHoc work app on my boss's iPhone running 4.2.1. I had to change a bunch of symbolic links in the XCode directories manually to even get it to install to 4.2.1 from the 4.1 SDK. I really hate the way Apple handles the iOS SDK.
     
  11. #11
    What benefit does this give the developer?
     

Share This Page