Two computers, how can I get Mail to not download messages from server?

Discussion in 'Mac Apps and Mac App Store' started by wwooden, Sep 5, 2005.

  1. wwooden macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #1
    As in my sig, I have both an iMac G5 and a 12" PB. I have one e-mail account, my gmail account that I use for everything. My problem is that when i turn on one computer and have it check for new mail, if it does find new ones if I open the other computer and start up mail, those messages are not in that mail account. I tried changing the account settings so that it doesn't "remove copy from server and retrieving a message", but this still happens. I just want the second computer to see the messages and show them as "read". Is this only done with iSync or whatever is the equivalent in Tiger? All the messages are still there on the gmail server because if I go to gmail.com and see them all. I feel like it is either a setting in my gmail account or in the mail app that can fix this.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2

    From memory, GMail is a POP account. My advice is to set up your account through the Mail preferences so that it removes email after one week. I've attached a screen shot for you, does yours look like this? This way, each time you start up your Mac, it'll sync with the GMail servers properly. It works for me.
     

    Attached Files:

  3. SpaceMagic macrumors 68000

    SpaceMagic

    Joined:
    Oct 26, 2003
    Location:
    Cardiff, Wales
    #3
    This setting in Gmail basically means it'll save all messages on the server as well - into "All mail." It doesn't mean that it'll make Mail.app believe that the mail hasn't been retrieved so that another app can download them again.

    Your best bet is .mac, as it'll sync them as "read" or "unread" if that's what you need.
     
  4. wwooden thread starter macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #4

    Yeah, that makes sense to me. Oh well, I'm not going to fork out $100 dollars just to have that feature.
     
  5. strydr macrumors 6502

    strydr

    Joined:
    Mar 25, 2005
    Location:
    SoCal
    #5
    Gmail POP

    I have the same problem. Even with the appropriate check boxes to leave a copy, it never works. Until Google offers MAPI connections, we'll just have to live with this bug.. My work around is to either set up a automatic forwarder to another account, or just manually forward messages I need on other machines.
     
  6. Tom Parker macrumors newbie

    Joined:
    Sep 8, 2005
    #6
    I don't believe that's altogether accurate, though. I have several POP accounts that I check from several different computers and I receive all mail with all mail clients -- provided I don't accidently allow one client to delete mail from the server. I don't know exactly how POP accounts flag mail as downloaded or read from a technical perspective, but in my experience POP mail that is left on the POP server WILL be re-downloaded by OTHER mail clients.

    I think this may be more related to gmail's handling of mail -- I believe gmail moves mail to a "read mail" location once you download it. I would try to duplicate this problem with another POP account before giving up. If it turns out to be gmail specific, I'd contact their support and see if there's some way to change what gmail is doing.

    tp
     
  7. strydr macrumors 6502

    strydr

    Joined:
    Mar 25, 2005
    Location:
    SoCal
    #7
     
  8. Tom Parker macrumors newbie

    Joined:
    Sep 8, 2005
    #8
    The problem is Google does some other stuff. Your client may be configured to not send the delete command once it has downloaded an email, but Google has some server-side processing that it does separately.

    I just looked at my gmail settings. When you enable POP mail, option 2 for POP download defaults to archiving messages after download. This is something Google does independent of your mail client. If you change that option to "Keep Google's Copy in the Inbox" it should clear up your problem.

    tp
     
  9. wwooden thread starter macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #9
    BEAUTIFUL!!! I think that solved my problem. It looks like both computers are downloading all the mail. Even though they are both showing them as new mail, they at least both get them. Thank you :)
     
  10. mb5828 macrumors newbie

    Joined:
    Jan 12, 2009
    #10
    Two computers, how can I get Mail to not download YAHOO from server?

    I have the same issue as above. Does anyone know any settings to solve this problem for Yahoo?
     
  11. jamesdmc macrumors 6502

    Joined:
    Oct 17, 2007
    Location:
    Cittagazze
    #11
    I'm glad you found a solution to your issue. But for the record, MobileMe can be purchased on eBay for a lot less than $100. It's value is in the eye of the beholder and can be debated at length (and it has been), but I just thought I'd thow that out there.:)


    James
     
  12. fiercetiger224 macrumors 6502a

    Joined:
    Jan 27, 2004
    #12
    Did you realize this post was made over 3 years ago? :p

    Anyway, the problem is this: POP is only designed to download new mail from the server. It does not sync in any way. All it does is if there is flagged new mail from the server, it downloads it to your computer, and you'll also have a copy of it on the server as well.

    IMAP solves these issues. It'll sync up with your email service, and whatever you do on your email, Mail will know. Say you deleted an email from the server. Mail will sync up with the server, and it'll know that you deleted that email, and put it in the deleted box.

    BTW, this thread is over 3 years old, and back then, Gmail didn't have IMAP support. It was introduced in 2007 I believe.
     
  13. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #13
    Tom, i apologies for such a late reply :p i woner if you even use MR anymore.. i have had the settings you specified enabled since 2007(according to gmail), but it does not work. when i retrieve the email from one computer it will not be retrieved from the other computer.

    any suggestions??
     

Share This Page