Two Safari Web Contents taking up 50+% when idle?

Discussion in 'OS X Mountain Lion (10.8)' started by Traverse, Jul 30, 2013.

  1. macrumors 601

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #1
    Hi,

    I'm having a really strange issue that just started a few days ago.
    I use Safari 6 as my main browser just out of personal preference. It as always had two entries in Activity Monitor: "Safari" and "Safari Web Content" and I knew what each of them were, but lately I have noticed significantly more power drain from Safari due to a second "Safari Web Content" that has mysteriously appeared. The first one acts like the normal "Web Content" using CPU and RAM only as needed, the second one uses little RAM, but sits at 20%-60% CPU (Usually around 50%) constantly, even when Safari is just sitting there with one tab.

    What is this second entry? When I quite it from activity monitor, Safari doesn't close like it would if you quite the normal entry and then it comes back......
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Your issues quite likely related to Flash content. For Flash-related issues:
    • Find your Flash version and make sure it's the latest version available. Never install or update Flash from a pop-up on a website. Always go to Adobe's site to get Flash or updates.
    • Install ClickToFlash (Safari), Flashblock (Firefox) or FlashBlock (Chrome) to control which Flash content plays on websites.
    • Try using the YouTube HTML5 Video Player to watch YouTube videos, when available. (May impact fullscreen viewing. See link for details.) Some have reported better performance with HTML5, while some have reported worse. Try it and find out what works best for you.
     
  3. thread starter macrumors 601

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #3
    Thank you, that sounds like a plausible possibility as it is worse on some sites than others. I will try your suggestion when I get home.

    However, I still have the "Safari Flash Player" entry in Activity Monitor in addition to the second "web content." The Flash Player entry has not displayed any odd behavior, it runs like normal on flash sites. Given that, could my problem still be Flash?
     
  4. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Yes, it could. Try the suggestions I posted, and report back if that doesn't clear up the problem.
     
  5. thread starter macrumors 601

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #5
    Thank, your advice has worked.

    It was my negligence, I was using an outdated Flash player due to laziness, I never realized it could cause that issue.

    I've heard of Click to Flash, but isn't OSX Mavericks going to fix those annoying Flash annoyances?
     
  6. macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6
    I urge you to use Click-To-Flash plugin and don't blame OS X for Flash's (Adobe) problems. So you heard wrong. IMHO using the Click to Flash & Click to Plugin and speed up your surfing. Even Windows users would see surfing speeds increase if they used similar plugins.
     
  7. thread starter macrumors 601

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #7
    You've understood wrong. I'm not blaming OSX for Adobe's poorly coded graphic renderer, but OSX Mavericks is suppose to incorporate a new Safari Power Saver feature that prevents Flash content from playing in ads and banners on the side of pages while allowing main content (such as videos) to play normally. This would alleviate the need for Click to Flash since it is designed to block the same thing. It would be one less program to have installed. If these new feature fails to satisfy me, I will try Click to Flash.
     

Share This Page