UK Virgin Broadband + D-Link 300G+ Setup...

Discussion in 'Macintosh Computers' started by TENBLUE7™, Feb 16, 2004.

  1. TENBLUE7™ macrumors member

    Nov 4, 2003
    Sheffield - England
    ...done a search and found a few threads but none specific to this config.

    So is anyone using an Ethernet Modem with Virgin Broadband in the UK? More specifically a D-Link 300G+? And how difficuilt | easy was it to setup?

    I've managed to get it all working locally but am waiting for a reply from Virgin re: addresses, settings and such.

    I rang the fabled customer helpline which I know understand is in India?? and the lady gave me only the IP address and some laughter at not having a clue what I was on about.

    This has given me the fear as I don't want to have just forked out over a £100.00 on a modem and the D-Link 604 router (due any day) when they cannot be used with Virgin Broadband.

    There's no way I want to carry on using two Speedtouch 330's and pulling USB connections out everytime I have to use the evil PC.

    Thanks in advance for any help or feedback.
  2. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    I had a 300G but couldn't get it to connect to the Airport Base Station for love nor money

    It was fine plugged directly into the Powerbook but wouldn't go online via the basestation.

    After trying for a few hours for a week, I ended up returning it (Micro Anvika had assured me it would work) and buying an Xmodem from
  3. TENBLUE7™ thread starter macrumors member

    Nov 4, 2003
    Sheffield - England
    ...I'm glad you had yours working, I'm ready for throwing mine against the wall.

    Unless I'm missing something obvious why configure it on the 192.168 address locally if you cannot modify the "PPP information" settings at the bottom of the page? When in the pdf install guide it says quote "enter your IP details" and you can clearly see that there are addresses in the two fields on said page.

    Any attempt at configuring it in the network preferences will obviously change the DHCP address losing the setup connection to the Modem.

    Do you configure it via Explorer or Safari or in the Network Prefs?

    If you where using Virgin Broadband what addresses did they supply you with if any?


  4. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    I was using BT Openworld

    I plugged into the ethernet port, waiting til its green light started flashing and opened up its 192.168 (whatever) through IE (it didn't like Safari)

    My location setting was 'connect through built-in Ethernet' and think I had the TCP/IP tab to DCHP done through System Prefs

    From the router pages, I had (from memory) and can't recall which pages each of these settinsg were on unfortunately or what order you'll find em in - but I did have them set to these which apparently are fairly standard in ADSL connections in the UK

    PPPoA, Use DHCP, VCMux with 0 and 38 in the nearby boxes, CHAP

    And appropriate user name and password.

    It all seemed to work fairly easily - it was when I brought in the wireless bit that I was tempted to throw it at the wall!

    I did also update the modem's firmware first time round

    Good luck
  5. TENBLUE7™ thread starter macrumors member

    Nov 4, 2003
    Sheffield - England
    Nice one, cheers for that.

    I've had one too many cans of Lager but I'll give it another go...:)
  6. TENBLUE7™ thread starter macrumors member

    Nov 4, 2003
    Sheffield - England

    You beauty it's now working!!!

    Cheers mate really appreciate your help on this, if I can ever help you out with anything web, graphic, flash, cinema4d wise.

    I'll have another can of Lager to celebrate I reckon.:D
  7. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    No problem! Good luck getting it working with the router - that's where I gave up!
  8. TENBLUE7™ thread starter macrumors member

    Nov 4, 2003
    Sheffield - England

    ...Router arrived this morning - followed the insert in the box and figured it would obviously be using PPPoE - works fine.

    I'm amazed.

    Even received a response from Virgin customer care giving me some details but obviously stating "we do not support your choice of hardware" nether the less it can be done and will work.

    Now all there is to do is to re-format my test PC that died thanks to some virus slipping through the firewall and anti-virus somewhere and get that setup on the LAN.

    So for anyone considering using a D-Link 300G+ ADSL Ethernet Modem with a D-link DI 604 Broadband Router WITH Panther (10.3.2) using Virgin Broadband as an ISP - It Works.

    So Far.;)
  9. cogito macrumors newbie

    Mar 29, 2004
    Airport and D-Link DSL-300G+

    Apple Airport Exteme Basestation with D-Link DSL-300G+ Broadband modem.

    How to get them to play together nicely…

    This took me weeks to figure out.

    I am using a 12 inch g4 powerbook, and a 12 inch g3 iBook and wanted them both to share my broadband connection, through an Airport basestation. Both computers are running Panther. My connection here in the UK is with Demon Internet, who provide a static IP address and use the PPPoA connection method.

    The situation was that I could connect to the internet fine when the D-Link modem was connected directly into the Ethernet port on my g4 powerbook. However, going through the airport basestation lead to nothing.

    The modem is one that is setup by using a web browser to browse to: (by the way Safari doesn’t seem to work so Internet Explorer has to be used).
    The computer’s Network settings need to be set to ‘using DHCP’ in the TCIP tab of the Airport configuration (and also the build in Ethernet configuration, if you are using the modem directly with your computer – which is what you should do first to check that your modem and settings are all ok). Once you can successfully connect to the internet this way, plug the modem into the WAN port of the basestation.

    The problem with the D-Link DSL-300G+ modem is that it locks on to the MAC (Ethernet) address id of the device that sets it up, and will only provide internet access for that computer. When I was putting up with using the modem via an Ethernet cable I would have to re-setup the modem every time I switched from powerbook to iBook. (In fact if you click ‘account configurations’ in the d-link setup page it lists the MAC address it is set for). So in order to have wireless internet, you need to get the D-Link to lock on to the basestation’s MAC address, and then have the basestaion act as a DHCP server with NAT etc.

    One temporary solution I had was to set the basestation to act as a bridge, by turning off ‘distribute ip addresses’. Then I could wirelessly log onto the D-Link’s setup page and have the modem lock on to my laptop’s airport card’s MAC address – but still not the basestation’s, so only one computer at a time could use the internet. For all computers on the wireless network to be able to access the internet, we need the basestation to distribute Ip addresses itself.

    My ISP provided me with a static IP number. Lets call it

    The Modem is supposed to act as a DHCP server, and I found that it did when it was plugged in directly to the Ethernet port of a computer, however it never seemed to work for the basestation. So I have to set it manually… ie set the ‘IP’ to and the ‘router’ to and the ‘subnet’ to – these settings I worked out by seeing what the modem provided by DHCP when plugged by Ethernet into the computer.
    However with this setup, I could not log onto - so I couldn’t setup the modem, which means it wouldn’t lock onto the basestation’s id.

    How to do it…

    In the Airport Admin, set how the basestation connects to the internet manually to:
    Ip address, subnet router to, and router to
    Then you can use Internet Explorer to set up the modem, it locks onto the basestation’s id. Great. (by the way sometimes you have to delete the configuration on the modem several times and keep redoing it before it locks on the new MAC address – because sometimes it remembers the one it had previously).

    Anyway, now you have to go and change the basestation config. The Internet settings have to be manually set up (setting it to use DHCP should work but didn’t seem to for me). The IP address should be the one provided by the ISP (eg, the subnet router to, and the router to one higher than the IP address (eg

    Some advice on the net has suggested that rebooting the modem, the base station and the computer in that order is a good idea.

    It should all work. Good luck.
  10. arimp macrumors newbie

    Mar 25, 2004
    I've had the Dlink DSL-300G+ ADSL modem for ages. I use plusnet as an ISP

    I had problem with it when I first had it.

    Orginally, I thought, get the modem working with my machine (to confirm Internet connection and then add the wireless router. Then I spend a couple hours trying to work out why my machine could connect to the internet, however nto via my wireless router when I changed the cabling.

    Then I woredk out that the ISP configuration you set to tied to the mac address you connected was was automatically cloning my mac address.

    RECOMMENDATION: Cable the Modem to you wireless router / airport that you want it then configure it with your ISP settings and IP address (if static).

    In terms of IP address, I left the DSL-300G+ at its default internal IP (, however configure the wireless router with a different IP range I use at home.


Share This Page