Um, iTunes Music Store switched to Japanese's..

Discussion in 'Mac Apps and Mac App Store' started by Philberttheduck, Nov 1, 2006.

  1. Philberttheduck macrumors 6502a

    Philberttheduck

    Joined:
    Mar 15, 2006
    Location:
    HB, CA
    #1
    Weird, I turned off iTunes and re-opened it. Then it popped up to the Japanese store and I noticed a lot of the things were japanese.

    Is there a way to turn it back to US? I can't find anything in preferences.
     
  2. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #2
    Go to the bottom of the store's main page and select US from the dropdown menu.

    Happened to lots of people today...here is one of the bigger threads on it.
     
  3. Philberttheduck thread starter macrumors 6502a

    Philberttheduck

    Joined:
    Mar 15, 2006
    Location:
    HB, CA
    #3
    Thanks much
     

Share This Page