Unable to change sound output when headphones are plugged in

Discussion in 'Mac Basics and Help' started by zen, Dec 8, 2012.

  1. zen
    macrumors 65816

    Jun 26, 2003
    I've got a new Mac mini with a Thunderbolt display. Most of the time I want to use the speakers on the display ("Display Audio"), but I also use headphones a lot.

    When the headphones are plugged into the Mac mini, the sound output system preference panel shows "Headphones". However, if I click on "Display Audio", it instantly flicks back to Headphones.

    Is there a way of changing the output, or am I going to have to plug and unplug my headphones constantly from the back of the Mac mini? This is awkward, given the position of the computer.
  2. macrumors 603


    That's the way it works, if the connector is inserted that's the only output you can choose, however you might google USB sound out, they might exist.

    Edit: Look at this for an idea.
  3. zen
    thread starter macrumors 65816

    Jun 26, 2003
    Annoying. Maybe time to invest in some Bluetooth headphones then.
  4. macrumors 603


    Or, my edit in my last post.
  5. zen
    thread starter macrumors 65816

    Jun 26, 2003
    Oh yeah, good idea.
  6. macrumors 603


    This was an example and you might find better deals or different devices, just look around first.
  7. macrumors newbie


    Jan 19, 2013
    Manhattan Beach, CA
    i was able to get my thunderbolt display to play sound while i have my headphones plugged in by going to midi pref and setting up a multichannel device and then that shows up in the sound pref and can select headphones or speakers, with out ever unplugging the headphones from the back of my imac 2012
  8. macrumors G5


    Jul 29, 2011
    Somewhere Back In The Long Ago
    The other way around this is to plug your Mac into a different audio device. Mine is connected to an onkyo AV system....when I want to use headphones I just plug them in there. Even a simple device would work as long as it has a headphone jack and an aux in port.
  9. macrumors newbie

    Sep 21, 2014
    Found a solution!

    I don't know if this question is still relevant, but I think I managed to solve this problem (Mac Mini Mavericks at least)

    First thing, go to Applications>Utilities>Audio MIDI Setup app

    In the bottom left corner of the window, click the "+" button and choose "Create Aggregate Device". It will create another device in the list.
    With this new device selected, in the right panel it shows a list of audio devices to use. Check the audio device that is not the built-in device. In my case, I checked the HDMI output related to my display speakers.
    Close this window.

    With the headphones plugged into the jack, open a video or music etc. The audio will be played through the headphones, as default.
    BUT now you can go in System Preferences>Sound>Output and choose the AGGREGATE DEVICE, and you should be able to make the sound play through it

    If you want a shortcut so you don't need to open the preferences every time to change the output, you can check the option "show volume in menu bar", to display the icon. Press and hold the "alt" key and click the sound icon in the menu bar, it will display a list of output devices, instead of the volume bar, and you will be able to choose it!

    Hope it helps!

Share This Page