Unable to open ~/Library/Keychains/login.keychain

Discussion in 'Mac Basics and Help' started by LittleJoe, Feb 11, 2007.

  1. LittleJoe macrumors regular

    Joined:
    May 23, 2006
    Location:
    Worthington, OH
    #1
    I put my Macbook Pro to sleep last night and when I came back it prompted me for my wireless login, which is odd because I have it saved in my keychain. Then it started prompting me for every password as I surfed the net. I checked my keychain and its empty! And any new password I try to save dosent save. I ran keychain first aid and I got this:


    Verification started
    Checking keychain configuration for Joseph Hauge (user ID=501)
    Home directory is /Users/josephhauge
    Checked login keychain
    Unable to open ~/Library/Keychains/login.keychain (-25312)
    Checked default keychain
    Checked keychain search list
    Verification completed

    Repair started
    Checking keychain configuration for Joseph Hauge (user ID=501)
    Home directory is /Users/josephhauge
    Checked login keychain
    Unable to open ~/Library/Keychains/login.keychain (-25312)
    Renamed /Users/josephhauge/Library/Keychains/login.keychain to /Users/josephhauge/Library/Keychains/login_renamed.keychain
    Repair terminated unexpectedly

    I also repaired permission in Disk Utility to no avail.

    Ive also tried to create a new Keychain and it says theres an error when I do so.
     
  2. LittleJoe thread starter macrumors regular

    Joined:
    May 23, 2006
    Location:
    Worthington, OH
  3. LittleJoe thread starter macrumors regular

    Joined:
    May 23, 2006
    Location:
    Worthington, OH
    #3
    Alright... for anyone who cares :rolleyes: I got it working again.

    though Im not sure how. I deleted the keychain file all together, but it would not let me create a new one. So i decided to just create a new user with admin privileges. I rebooted and went to the new user and everything worked fine with the keychain. I logged out and went back to the old keychain and now that was working fine! And not only was it working fine but it had all my old passwords and such!??!? Huh? I deleted those! Whhhaaatever. It's working fine now. Thanks for the help... :p
     
  4. annk Administrator

    annk

    Staff Member

    Joined:
    Apr 18, 2004
    Location:
    Somewhere over the rainbow
    #4
    Well, if it's any comfort, I'm glad you posted, and especially that you posted the solution. :) I wouldn't've been able to help, and only saw this thread now, but now I know what to try if my keychain does something weird. :eek:
     

Share This Page