Undeclared Error and iPhone Simulator Crashing

Discussion in 'iOS Programming' started by stangmmx, Jun 6, 2011.

  1. macrumors member

    Joined:
    Nov 30, 2008
    #1
    Here is my code from a simple test app I'm practicing with.

    I'm using the beginner's iPhone dev book, and it's good, don't get me wrong, it's just sometimes there are errors with the code. Anywho, could anyone help me out with this one?

    I'm a complete novice so, it's probably a simple fix. Thanks.
     
  2. macrumors 65816

    jnoxx

    Joined:
    Dec 29, 2010
    Location:
    Aartselaar // Antwerp // Belgium
    #2
    As far as I know, there is no problem with the code, but a problem with your NIB file? (XIB in other words.)
    Any chance u made a mistake there, with outlets etc.
     
  3. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    Accuracy is important when programming, as well as when seeking help for programming. What is the exact title of the book? Also, it usually helps to include the author and edition.
     
  4. thread starter macrumors member

    Joined:
    Nov 30, 2008
    #4
    Here's the text I am using.
     
  5. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #5
    Books aren't perfect either. But, if you think you've followed directions to a tee, and it still doesn't work, first place I would check is the book's errata. Plus, this book has its own website with forums that are very helpful and visited by at least one of the authors where you can also get help on errors you find.
     
  6. stangmmx, Jun 7, 2011
    Last edited by a moderator: Jun 7, 2011

    thread starter macrumors member

    Joined:
    Nov 30, 2008
    #6
    You're right. I was being a bit careless with my NIB file. Thanks for looking over my code though.

    Yes. The link in my original post is a link to a post I made in the author's/books forums. It's just not a very active forums. Appreciate the help
     
  7. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #7
    Oops, sorry. Hadn't noticed that. My apologies.
     

Share This Page