Unique issue with AppleTV and Mac Mini

Discussion in 'Apple TV and Home Theater' started by jthesssin, May 8, 2013.

  1. macrumors member

    jthesssin

    Joined:
    May 6, 2013
    Location:
    Matthews NC
    #1
    Hello all! I have what I think is a very unique issue. Let me start by laying out the system:
    AppleTV 3rd generation via HDMI to a Pioneer VSX1120 receiver.
    Mid 2010 Mac Mini via HDMI to the receiver (its my HTPC for surfing the net and working).
    The receiver is outputting to a 55" Samsung LED via HDMI
    iTunes media/library is stored on a 2TB time machine

    After I turn on the AppleTV I normally select my iTunes (by selecting computers) library in order to watch one of my handbrake ripped DVD's. any time I pause, or otherwise change my viewing (switching to my purchased movies, or Netflix) the Mac Mini will start playing music via the inboard speaker. I then need to switch inputs and stop the music by pausing it.

    If I use the ATV to watch Netflix or stream my purchased movies from the iTunes Store I do not have this problem, only when streaming from my iTunes library.

    Anyone with ideas on how to stop this would be a life saver. Is there a way to simply play a movie directly from the time machine even if iTunes is not running (this means my home sharing is turned off)?
    Thanks!!!
     
  2. macrumors 68030

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    No.

    Sounds like you need to put some black electrical tape over the IR sensor on your Mac Mini. I'm guessing it's responding to the remote when you're changing movies on the ATV.

    Ed: I'm sure there's a software solution that doesn't involve tape but you get the idea :)
     
  3. macrumors regular

    Joined:
    Aug 15, 2012
    #3
    Yes your Apple TV remote is causing your Mac mini to respond and do funny things when your itunes is open on your mini. You can disable the IR on the mini in system preferences, under security select advanced options and make sure disable IR is checked off.
     
  4. macrumors 65816

    lunaoso

    Joined:
    Sep 22, 2012
    Location:
    New England, USA
    #4
    Or you can pair the remote to the Apple TV in settings>general>remotes>pair remote. This should fix it.
     
  5. macrumors 68020

    Joined:
    May 27, 2008
    #5
    no it wouldn't, pairing the remote only causes the receiver to listen to a specific remote. the mini would still respond.

    each apple remote contains an ID code (0 to 255), when you hit a button it sends the button and the ID code so "play-234"
    pairing tells the receiver to listen only to a specific ID, and ignore the rest.
    an un-paired reciever will listen to all codes.

    you would have to pair the mini with a different remote for it to ignore the aTV remote. or as jdblas69 turn off the receiver.
     
  6. macrumors 65816

    lunaoso

    Joined:
    Sep 22, 2012
    Location:
    New England, USA
    #6
    Oh my bad. I have one of each of my remotes paired with my Mac mini and Apple TV so I just figured that's how it worked. Guess I learned something today. :)
     
  7. macrumors newbie

    Joined:
    Jan 13, 2013
    Location:
    Bainbridge Island, WA
    #7
    Yea.. Just pair one remote with ATV and the other with Mini.

    Or... Do what I do and use a remote with the ATV and a Wireless Touchpad with the Mini. The Touchpad makes a great remote for the Mini.
     
  8. thread starter macrumors member

    jthesssin

    Joined:
    May 6, 2013
    Location:
    Matthews NC
    #8
    It worked.....

    Thanks for the suggestion on the iR disable... never even knew my mini had an IR receiver. Sorry about not responding. I assumed I would get an email if someone posted a reply to my original post so I wasn't looking :)

    Again, Thanks everyone!
     
  9. macrumors 65816

    Joined:
    Mar 23, 2013
    #9
    Haha, I had the exact same problem.

    Just go (in OSX) to System Preferences>Security and Privacy

    Then click on the padlock to unlock it and add password.

    Then tick 'Advance' and the bottom right and click 'Disable remote control infrared receiver'.

    The guys at Apple though long and hard about that option when they put it under 'Security and Privacy'. :rolleyes:

    Edit: sorry I just realised you have two remotes. My suggestion works to stop the remote working on the mini. Having said that, you can pair or unpair in that setting anyway so that might help. Check it out anyway.
     

Share This Page