Unreal Tournament 2004 Problem

Discussion in 'Games' started by longey, Sep 5, 2006.

  1. longey macrumors newbie

    Joined:
    Jan 26, 2006
    #1
    hey guys,

    i just got a copy of Unreal Tournament 2004 for my iMac g5 from the apple store, an it installed fine no probs there, BUT the max resolution i can do is 1024x768 an it looks odd full screen an i hate playing windowed mode its weird, like ive bought RCT3 an SIMS2 an they run on the native resolution of 1440x900,:confused:

    is there anyway to make it run at 1440x900??? at the native resolution

    thanks:)
     
  2. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #2
    Custom resolutions are no problem:

    1. Open your user Library folder > Application Support > Unreal Tournament 2004

    2. Open ut2004.ini in TextEdit and do a Find for "fullscreen."

    3. Change the lines to read:
    FullscreenViewportX=1440
    FullscreenViewportY=900

    Warning: if you run the game on an external display that can't handle that res, it will exit. Just re-edit those lines to something it can handle. (This happens to me when I run the game to my TV.) Or, before you hook up the display, change the res using UT's GUI.

    While you're at it, make sure you have the latest patch from http://macgamefiles.com and read the end of the readme: it tells you how to enable realtime shadows and render-to-texture (vanity plates for Hellbender etc.) by changing your .ini files. Looks cool and doesn't have much performance penalty :)

    It's a great game with zillions of free maps and add-ons.

    http://www.mapraider.com/maps/searc...arch&gamesystem=7&gametype=&gamestyle=&score=

    http://nalicity.beyondunreal.com/search.php

    http://www.planetjailbreak.com

    http://chaotic.beyondunreal.com

    http://www.blackcatgames.com/swarm

    http://u4e.beyondunreal.com

    http://www.ataricommunity.com/forums/showthread.php?s=&postid=5587626

    That barely scratches the surface.

    But then I'm biased :) (See sig.)
     
  3. longey thread starter macrumors newbie

    Joined:
    Jan 26, 2006
    #3
    its a no go :(

    I went Library > Application Support > Unreal Tournament 2004

    and found these an changed the text an saved it as
    FullscreenViewportX=1440
    FullscreenViewportY=900

    an then launched the application an it hadnt changed in game i check settings an the was no 1440x900 setting in there, i went back an even changed the windowed mode an menu setting in the ut2004.ini but it hasnt changed :confused:

    am i doing something wrong???

    thanks :)
     
  4. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #4
    Did you change this section?

    Code:
    [SDLDrv.SDLClient]
    WindowedViewportX=640
    WindowedViewportY=480
    FullscreenViewportX=1280
    FullscreenViewportY=854
    MenuViewportX=640
    MenuViewportY=480
    Brightness=0.800000
    Contrast=0.700000
    Gamma=0.800000
    UseJoystick=False
    JoystickNumber=0
     
  5. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #5
    Oops -- search for "[SDLDrv.SDLClient]" -- there's a similar Windows section which isn't relevant.

    EDIT: What bousozoku said - and nice PowerBook G4 :)
     
  6. longey thread starter macrumors newbie

    Joined:
    Jan 26, 2006
    #6
    hey,

    thank you so much :) it works perfectly now, at 1440x900 an looks sweet the problem was i went to the wrong part the second thing worked fine

    thanks again i never would have worked it out :eek:

    Happy Gaming:)
     
  7. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #7
    You'll find that you will often change the .ini file to suit your needs. There are things in there that are not mentioned in the in-game menus, such as anisotropic filetring. When changing things, make sure you are changing the right section. You should only change the OpenGL sections or SDL sections. The Direct3D is not supported on Macs (since it doesn't exist at all).
     

Share This Page