Unreliable Wi-Fi on C2D MBP

Discussion in 'MacBook Pro' started by Gaokaos, Dec 13, 2006.

  1. Gaokaos macrumors newbie

    Nov 22, 2006
    Hi all, I have been using my mbp on my wireless network without problems for almost two weeks now. But during the last days I have experienced an extremely unreliable signal from the network. In the past it was always near the maximum quality, but now it just revolves between maximum and minimum, and whats worse, it drops the signal regulary, this is extremely annoying for applications like irc and msn.
    I can't think of anything that I changed to either my macbook, router or the environment recently so I have no idea what is jamming my signal. I did install a torrent client, but I also have the problem when the program isnt running. ( is there an easy way to monitor network activity in os x? )

    On a related base:
    I wasnt able to connect to my friends wep-secured network even after literally copying the wep key. We tried several times but always got a connection error. Removing the wep security was the only thing that worked. Both my psp and sony laptop were able to connect using that same wep key.
  2. VforVelveta macrumors regular


    Nov 16, 2006
    Cedar Rapids, Iowa
    Not too sure about the dropping the signal problem, but I might have a solution to the WEP kep problem, as I ran into a similar problem.

    Apparently Macs handle WEP keys a little differently than Windows machines do, and need to be told that the WEP key is in hex. What I had to do was to get the WEP key in hex, then before typing it in, put a $ in front of it. (Pretty sure it was a $, though you might want to double check that)

    If you didn't already, you might want to try that. Hope it helps.
  3. phuong macrumors 6502a

    Aug 16, 2006
    interesting. what you are saying is, the password should have an extra "$" in front of it?
  4. MarkR macrumors newbie

    Dec 13, 2006
    Brighton, MI
    After you log in to your MBP, you can go to the Networking Dialog box for Airport, select the network you want to use, and then select WEP Hex from the security type dropdown. This is not an option when you first setup your Mac (I don't know why). I had the hex password saved in my keychain.

    This helped me deal with WEP issues and everything works great.
  5. richard4339 macrumors 6502a


    Sep 6, 2006
    I have noticed the shoddy reception; when I'm in class (using wireless zero authentication), my neighbors will all have perfect reception, and I won't even be able to connect to the network.

Share This Page