Unresponsive drive???

Discussion in 'Mac Basics and Help' started by lexus, Nov 11, 2006.

  1. lexus macrumors 68000

    lexus

    Joined:
    Mar 26, 2006
    Location:
    Depends Greatly On The Weather
    #1
    I use a Lacie Rugged drive for all my TV shows and when I plugged it in it works(disks spin) but does not show up anywhere. What should I do?

    Thanks
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Does it not even show up in Disk Utility? Did it ever show up on this machine? Is the drive getting enough power and is there another device plugged into the Firewire or USB ports on this Mac? :)
     
  3. lexus thread starter macrumors 68000

    lexus

    Joined:
    Mar 26, 2006
    Location:
    Depends Greatly On The Weather
    #3
    Yes it shows up in Disk Utility and when I try to repair it it gives me some Sibling error.
     
  4. Willis macrumors 68020

    Willis

    Joined:
    Apr 23, 2006
    Location:
    What feels like the middle of nowhere
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Maybe post the error you get in Disk Utility to see if we can decipherer it. :)
     
  6. lexus thread starter macrumors 68000

    lexus

    Joined:
    Mar 26, 2006
    Location:
    Depends Greatly On The Weather
    #6
    Here,

    Thanks
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia

Share This Page