Updates keep stalling - anyone else having trouble?

Discussion in 'iPad Apps' started by MartyCan, Nov 23, 2012.

  1. macrumors 6502a

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #1
    I've been having a lot of trouble with the App Store and updates lately. Is anyone else having trouble like this?

    Here's what happens;

    I get an update notification. So I go to the App Store to "Install" or "Update All" if it is more than 1 App. I click and it says "Updating" but then there is no progress shown. Just the empty bar that should be turning blue. If you return to the home screen the App or Apps show "Waiting." In some cases I've left the device all day and on return home it has still not changed.

    It is happening with a bunch of different Apps and it has not been consistent across devices. One that would not install on the 3 did install on the Mini.

    I've tried force-closing the App store and restarting it. I've powered the iPad off and re-started. Still no luck. Finally all I can do is delete the app. Fortunately most have been "throwaway" free apps that I tried out of interest but some are apps I really want.

    It has happened with my iPad 3 and my iPad mini. The 3 is WiFi+Cellular. My wife has had the same problem but she said force-closing the App store and restarting it resolved it for her.

    If this was a one-off I wouldn't care but this has happened for a few weeks nw.

    Anyone else had this issue? Any known fix?
     
  2. thread starter macrumors 6502a

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #2
    An update.

    Just to test I have tested both WiFi only and Cellular data only on my iPad 3 with the same result. Te app shows installing but there is no progress.

    My home cable (for the WiFi) is Rogers but my Cellular plan is with Bell. I don't think the problem is at my end. Others must be having an issue?
     
  3. macrumors regular

    Joined:
    Mar 20, 2008
    #3
    What apps in particular do this?

    All apps or some apps?

    Do you have the latest iOS installed on the device where it's frozen?

    On the devices on which it stalls, do the apps on that device all belong to one iTunes account, or do you have a mixture of apps from several iTunes accounts on it?

    If it has several accounts on it, do the stalled apps belong to the user current user that is logged in to the App Store app?

    Have you shut down all apps from running in the background and rebooted to try that?

    Have you turned off wifi and relied on 4G service ( if you have 4G service ) ?

    If not 4G service, have you tried to reboot your wiFi router?

    Hopefully, some of these question might trigger you doing something to get past this stuck condition ... I've been there before as well ...
     
  4. thread starter macrumors 6502a

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #4
    Apps are random. Some work, some don't and not consistent from one device to another.

    All devices are on latest up to date iOs.

    Have tried it with only 4G running (wiFi off) on the 3 and also with WiFi only with the Cellular switched off.

    Have not tried shutting all apps down in background, but really that is more of a recently used list isn't it? Many time when I recall an app from there it launches like it was not open.
     
  5. thread starter macrumors 6502a

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #5
    Latest update - still confused.

    My iPhone 5 showed their was an update for Docs To Go (purchased FWIW). This is an app that has been giving me fits trying to reinstall on the iPad 3. But I clicked update and it d/l'ed in seconds.

    Then as a test I tried installing it on the Mini (WiFi only) from the previously purchased list and it also installed no problem.

    Then I tried to do the same on the 3 (again) and it shows installing but does not make any progress. Not even a pixel of blue in the progress bar.

    I also tried getting all updates using iTubes on my MBP and synching via cable. It worked getting two other apps back on but not Docs To Go.

    Thinking that next step will be a factory reset and restore.
     
  6. thread starter macrumors 6502a

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #6
    Went with a factory reset and restore from back-up. Seems to have done the trick.
     

Share This Page