Upgraded Video Card - No Change in Performance

Discussion in 'Mac Pro' started by aviationwiz, Mar 24, 2006.

  1. aviationwiz macrumors regular

    Joined:
    Apr 2, 2005
    #1
    So I upgraded from a GeForce FX 5200 Ultra with 64 MB RAM to a Radeon 9600 Pro with 256 MB RAM in my Dual 1.8GHZ PowerMac G5.

    I installed the drivers, made sure they were up to date, and fired up World of Warcraft. Low and behold, I get the exact same frame rates, around 15-20 fps. Anyone have any ideas as to why my performance isn't improved?

    I also upgraded from 768MB DDR to 1.5GB DDR RAM (all Crucial) you would think that would help it a little too.
     
  2. Kingsly macrumors 68040

    Kingsly

    #2
    I had the same thing happen with Motion. I got the biggest GFX card they make and 4 GB or ram and saw no improvement in Motion.
     
  3. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #3
    The truth is that Radeon 9600 isnt much faster in gaming than FX5200, but the framerate should be higher :confused:

    When I "upgraded" from GeForce 2 MX, 700 MHz G4 and 0.64 GB RAM to Radeon 9600 Mobility (even underclocked), 2000 MHz G5 and 1.5 GB RAM, I saw a huge improvement :D
     
  4. dmw007 macrumors G4

    dmw007

    Joined:
    May 26, 2005
    Location:
    Working for MI-6
    #4
    Very odd, I would thought that you would have seen a decent improvement in performance after your upgrades. :confused:
     
  5. Josh396 macrumors 65816

    Josh396

    Joined:
    Oct 16, 2004
    Location:
    Peoria/Chicago, IL
    #5
    Yeah me too. Even as eXan said, it's not a much faster video card but I would think the framerate would see at least some improvement.
     
  6. CubeHacker macrumors 65816

    CubeHacker

    Joined:
    Apr 22, 2003
    #6
    Try deleting the WTF folder (i forget if its the entire folder or just the ini). It might reset the WoW settings and allow it to redetect your video card and get a performance boost. It can't hurt at least. Also, there shouldn't be any drivers to upgrade - they all come as part of software updates.
     
  7. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #7
    Check your options in the games. I've found after changing video cards that the game still thought the old card was there.
     
  8. aviationwiz thread starter macrumors regular

    Joined:
    Apr 2, 2005
    #8
    I deleted the WTF folder (which houses all local settings) and the performance is still the exact same. Not one more frame per second.
     
  9. SmurfBoxMasta macrumors 65816

    SmurfBoxMasta

    Joined:
    Nov 24, 2005
    Location:
    I'm only really here at night.
    #9
    huummm......if the card is NOT any faster, then WHY would the framerates be any higher....... apparently you ARE :confused: :D

    SO, you went up a cpu generation, nearly tripled the CPU speed & ram amount, AND upgraded the video card..... Did you NOT expect a performance increase ? now I'm :confused:
     
  10. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #10
    The 9600 is ***** for motion. Seriously it's a duff card regardless is it comes with 64,128 or 256mb flavors. More memory for textures is stupid when the core set of components cant drive them... Bad choice and not an upgrade from the Geforce 5200...


    Stick an X800 XT inside and you'll see serious improvement. I get excellent framerates in wow with everything on max, 4 x antialising on 1680x1050 resolution.

    Motion needs a fast GPU. Your gpu isn't even one that's recommended. Again stick in the X800Xt or Geforce 7800 and it's a whole different application....


    Just a bad choice of upgrade I'm afraid.
     

Share This Page