Upgrading question

Discussion in 'PowerPC Macs' started by lbmontez, Jun 12, 2011.

  1. macrumors member

    Joined:
    Jun 12, 2011
    Location:
    Texas
    #1
    So, I've bought an iBook G4 "Late 2005" version. It has 10.4.11 installed on it, and I want to upgrade to 10.5.

    When I perform the upgrade, will it wipe everything off of my machine? It's coming with Office '08 and I don't want to lose it.
     
  2. macrumors 6502a

    stroked

    Joined:
    May 3, 2010
    #2
    You shouldn't loose anything with an upgrade. I would clone the HDD first using Carbon Copy Cloner first, just in case something goes wrong.
     
  3. thread starter macrumors member

    Joined:
    Jun 12, 2011
    Location:
    Texas
    #3
    Will this just copy it onto my external drive?
     
  4. macrumors 6502a

    stroked

    Joined:
    May 3, 2010
    #4
    Yes, and if you have a firewire drive, it will be bootable too.
     
  5. thread starter macrumors member

    Joined:
    Jun 12, 2011
    Location:
    Texas
  6. macrumors 65816

    adcx64

    Joined:
    Nov 17, 2008
    Location:
    Cudi Zone
    #6
    When in the Leopard installer, just select make sure you don't select "erase and install" and ull be fine!
     
  7. thread starter macrumors member

    Joined:
    Jun 12, 2011
    Location:
    Texas
    #7
    Side note question: does anyone know a link to get the latest version of iTunes for 10.4.11?
     
  8. macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #8
    9.2.1 is the last version for a G4, here's the download link.

    http://support.apple.com/kb/DL1056
     
  9. macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #9
    im running leopard on my ibook G4 and with updates itunes is showing version 10.3.1
     
  10. thread starter macrumors member

    Joined:
    Jun 12, 2011
    Location:
    Texas
    #10
  11. macrumors 68020

    Joined:
    Feb 19, 2011
    #11
    Just to confirm that, system requirements for the latest available version of iTunes:

     
  12. macrumors 6502a

    stroked

    Joined:
    May 3, 2010
    #12
  13. macrumors 68020

    Joined:
    Feb 19, 2011
    #13
    Uhuh. I think 9.2.1 was the last version to run on Tiger, so I'm guessing that's what cocacolakid was thinking of.
     
  14. thread starter macrumors member

    Joined:
    Jun 12, 2011
    Location:
    Texas
    #14
    ^^Agreed. It's working! :) Next step with this laptop is to upgrade the memory a bit and Im good.
     
  15. macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #15
    Yes, 9.2.1 is the last version for a G4 running Tiger, as the previous poster I answered was looking for.
     

Share This Page