Urgent!...Manual Unmount Help Needed...

Discussion in 'OS X Mountain Lion (10.8)' started by JoelBC, Dec 6, 2012.

  1. JoelBC, Dec 6, 2012
    Last edited: Dec 6, 2012

    macrumors 6502a

    #1
    I have a real and urgent need to unmount a hidden share from my NAS drive...

    I am using a WD ShareSpace NAS for TimeMachine...following the instructions contained in another thread [see http://forums.macrumors.com/showthread.php?t=1463343 ]I mounted the NAS' hidden share using the following terminal command

    sudo tmutil setdestination afp://wd_backup:backup@192.168.5.150/WD_Backup

    where wd_backup = share's user name, backup = share's password, 192.168.5.150 = NAS' address and WD_Backup = share's name

    I now need to unmount the drive but can not figure how to do so please help me by providing me with the necessary terminal command to do so [i.e. to be clear, I need / want to unmount the drive so that it DOES NOT appear as a backup device within TimeMachine).

    Thanks for all your help,


    Joel


    PS. Once I have your attention, does anyone know how to access this share on the NAS drive to recover the space with the issue / problem being that it is hidden?
     
  2. macrumors 603

    justperry

    #2
    Since you didn't get a response yet I give it a try, I know OS X fairly well but I don't understand this here.

    If a share is mounted it should be in the finder/ on desktop and you can drag it to the trash.
    I mount disks/folders over the net with Command-K and they show up in those locations but it depends how your preferences are set.

    I could be completely of here so excuse me if I am totally wrong.
    Tried to search the net for you but couldn't find the unmount command either.
     
  3. macrumors 6502a

    #3
    Appreciate the assistance but unfortunately that did not work...i think -- just guessing here -- that the problem is related to the fact that the terminal command that I issued acts as a "hard / permanent" which is making it difficult to unmount the drive.

    Hopefully someone else will have the answer.

    Thanks,


    Joel
     
  4. justperry, Dec 6, 2012
    Last edited: Dec 6, 2012

    macrumors 603

    justperry

    #4
    Sorry that did not work, but found this link on Apples site, the Man pages for tmutil.

    I saw one 'verb' there, disable, might help.

    Edit: You might try to look for timemachine preference file and look if there is an entry in it and if so delete the link.

    com.apple.TimeMachine.plist

    I found two .plist files, but I don't use Timemachine nor shares.

    Found the files by using a free app called EasyFind.
     
  5. macrumors 6502a

    #5
    Again, appreciate the help but no luck in that:

    1. The "disable" command simply disables automatic backups...I need a commend that is the opposite of set destination [i.e. I need a remove destination / reset destination or other similar command].

    2. I looked at the plist files could find nothing there.


    Thanks,


    Joel
     
  6. macrumors 603

    justperry

    #6
    What if the TimeMachine is disabled and then enable it again, this can be risky though.
    It might be that if it is disabled all settings are lost, this also means a new setup and I don't know what TimeMachine does after it is started again after a new Setup.
     
  7. macrumors 6502a

    #7
    I do not care about loosing my backups at this point...I just want to unmount the drive...
     
  8. macrumors 603

    justperry

    #8
    Well, then disable TimeMachine.

    Hope this works.
     
  9. macrumors 6502a

    #9
    That will not help as the share will still be mounted...I need / want the share gone...
     
  10. macrumors 603

    justperry

    #10
    If this is so I think Apple messed up, it is TM related and it should also disable this share.

    There is also this in /Library/Preferences/SystemConfiguration

    These are normally all network settings, I don't have shares but I do see some interesting files in the like com.apple.smb.server.plist
    There might be a .plist there.
    There is more, check them out.

    Hope that they are in the same place as your OS, I am on an earlier OS but do have TM.
     
  11. switon, Dec 6, 2012
    Last edited: Dec 6, 2012

    macrumors 6502a

    #11
    RE: umount...

    Hi,

    Speed-reading through your posts, I wasn't clear if all you really want is to unmount an afp share. If this is all you wish to do, then have you tried the "umount" Terminal command? (Note that it is "umount" and not "unmount".) Here is an example terminal command that unmounts an AFP share:

    umount //username@servermachine._afpovertcp._tcp.local

    where you can discover the exact name to use through the "df" terminal command:

    df -h

    which returns the "//username@servermachine._afpovertcp._tcp.local" for whatever name your share is actually afp mounted as.

    Obviously, you will need to have the privileges of "username" in order to execute this command, or you can execute it from a root account or using "sudo" from an Administrator account.

    Good luck,
    Switon

    P.S. The "umount" command has a number of options, such as forced unmounting, that you can read about using "man amount".

    P.P.S. By the way, you can use "umount" to also unmount the mount point, as in:

    umount /Volumes/share_name
     
  12. macrumors 6502

    rhoydotp

    #12
    can you type the command "mount" and share the output

    thx
     
  13. macrumors 6502a

    #13



    Appreciate the response...

    A few follow ups as I continue to be confused [and, apologies, as I am new to all this Mac stuff]:

    1. Correct, I am looking to do nothing more than unmount an AFP mounted drive albeit one that was mounted using the "tmutil setdestination" command to the extent this makes a difference / matters.

    2. I entered the command df -h in terminal as you suggested but did not a response a long the lines suggested above...in its place I got a table with the headings filesystem, size, used....,mounted on.

    I therefore do not know how to proceed.

    I wonder whether this is because of the method I used to mount the drive per 1. above [i.e. using the "tmutil setdestination" command].

    I wonder whether this has to do with the fact that I am at present connected to the network via VPN.

    3. In the hope that we can overcome 2. above kindly confirm that the username [and the password that is subsequently requested] is that for the mounted share [as opposed to that for the MacBook, the NAS in general, etc.]

    I seem to be way over my head and really wanted this sorted...I have invested 100+ hours trying to make the move from Windows to Mac but everything seems to be a challenge...I am almost there in terms of getting my Mac setup so hope that I can get this done and keep my Mac.

    Thanks for all the help.


    Joel
     
  14. macrumors 6502a

    #14
    RE: more info...

    Hi Joel,

    Sorry, I should have explained more.

    Yes, using the "df" command returns a table of all of the mounted volumes, including shared volumes. Hopefully, one of these lines is your mounted TM afp volume. You will have to recognize which line it is. For instance, for my TM backups, the "df" line is:

    /dev/disk2s2 1.8Ti 416Gi 1.4Ti 23% 108992788 378777580 22% /Volumes/Time Machine Backups

    You can then use the "umount" command as described earlier. Sometimes "umount" fails, then try the "diskutil unmount /dev/disk2s2" where /dev/disk2s2 is the name appropriate to your system.

    Lastly, you aren't attempting to use your boot volume also as your TM backup partition, are you? If you are, you won't be allowed to unmount it.

    Switon
     
  15. macrumors 6502a

    #15

    @Switon

    Appreciate your explanation and all of your help, truly...

    I do not know what happened or how I did it but the afp mounted share is no longer showing itself in TimeMachine...I hope that it is truly gone and does not re-appear when I get back home this evening...in the event that it does I may be back for more help...

    I have concluded that I am staying away from AFP, TMUTIL related and other terminal commands until I get more Mac compliant / comfortable...

    No -- just to respond to everything -- I was not using my boot volume rather I was using my NAS drive...

    The lesson that I have learnt is that while it is possible to use a non-Apple device [i.e. WD ShareSpace NAS] it is far easier not to do so...the number of hours waste on this little exercise was unbelievable.


    @ All

    Appreciate all the help and hopefully will not be back when I get home as noted in the immediately preceding text...

    As far as TimeMachine is concerned I also discovered that it takes snapshots while NOT connected to your TimeMachine device...these are in a hidden volume named MobileBackups....to get rid of these simply enter the command "sudo tmutil disablelocal"

    Though I said I would stay away from Terminal commands I would think this would be a good exception given that these slices can become quite large in time.

    Though it may be me I am begging to think that TimeMachine is not for me given the challenges / problems that I have experienced over the last two days...perhaps something like backuplist+ [see http://www.macupdate.com/app/mac/21413/backuplist+] or carbon copy cloner [see http://www.macupdate.com/app/mac/7032/carbon-copy-cloner ] would be better and easier...what are your experience / thoughts on this.

    Thanks,


    Joel
     
  16. macrumors 603

    blueroom

    #16
    IMHO TimeMachine backups are great, I use a Synology NAS though, which is very flexible.
     
  17. macrumors 6502

    rhoydotp

    #17
    the Timemachine to NAS (AFP/CIFS/SMB/NFS) is a hack. Apple does not officially support it. Timemachine with a disk directly attached to it is great and has been working for a lot of people since it first came out.
     
  18. macrumors 6502a

    #18
    Help!!!

    I am completely disappointed....I get home and the drive is back again...where to we go from here noting the following:

    1. I enter "df -h" and the mount does NOT appear...I see no reference to the drive...


    2. I move my cursor over the drive in TimeMachine and I see the following "afp://JoelcHomeNAS/WD_Backup


    3. I tried entering "sudo umount //wd_backup@JoelcHomeNAS/WD_Backup"....I get prompted for a password but the drive remains mounted.


    4. I tried "sudo diskutil umount //wd_backup@JoelcHomeNAS/WD_Backup"....I get prompted for a password but the drive remains mounted.

    This is driving me nuts....please help...

    Thanks,


    Joel
     
  19. macrumors 6502a

    #19
    Guys...I need serious help...I wiped my entire hard drive, did a clean install and to no avail as their must be some reference on the NAS drive that is looping back to the MBA...NOT happy...

    Does anybody have any idea as to how to kill this link as my MBA is useless until it is killed...

    Thanks,


    Joel
     
  20. macrumors 6502a

    #20
    Gents, this situation is unbelievable...given that I could not figure out how to unmount this drive I decided that i would try to disassociate it by i) changing the server name ii) changing the static IP address and iii) changing the password but the damn thing morphed in that it still showed as a "TimeMachine available disk"...how can this be given that the command used to mount drive [see post 6 on this thread] contains the server name / IP address and password...

    This is getting me to think that through this process something has been put on the server which is finding its way back to my MBA...very disturbing....

    Well, the only thing that is obvious is that I need help...
     
  21. macrumors 603

    justperry

    #21
    I will comment on the bold below.

    First, I though I would create the situation like yours myself, I do have a AppleTV (version 1) with OS X installed so I made a afp share, but in terminal I could not use the command, seems like my Leopard does not have the tmutil Command.

    What I did see though is that when I select a drive for TimaMachine it creates a file on that network drive, it is invisible though and on the drive it is named: .001124413ce8 , I opened it up but did not show much, this is the text : Ÿ∑ËAíTK‰∂,$ΩÂ≤fÇ

    Now, on the bold, you said you completely wiped the drive yet it came back, this can mean only one thing, there is a setting on the NAS which will push the drive to mount on your Mac, there is simply no other way it could happen since you wiped the disk.

    You could try to delete the file I mentioned, I am not sure though if it is called the same, it was/is at the root level of a disk, I choose another external Firewire disk for TimeMachine to use and it created the same named file, so if you want to know what the name is in your case then just switch on Timemachine on a different disk and see the file created.
    Be aware though, it is invisible and you have to make files visible before you can see it.
    But, it might also be some other protocol which I am not aware of, lets say the command you entered switched something on in the NAS, it will have it's own setting somewhere and here it gets too difficult to solve.

    See Screenshot below.
     

    Attached Files:

  22. macrumors 6502a

    #22
    Thanks, I find this to be totally unbelievable...hopefully someone has an answer...as a start I am going to back up all the data on my NAS today in case I do in fact need to reformat my NAS drive....


    Joel
     
  23. macrumors 603

    justperry

    #23
    If you do unplug the NAS the share should unmount, probably after a dialogue box in OS X that warns you a disk has unsafely been removed, if not then some ghosts are playing with your mac.

    Edit: you did not mention how it is connected, wired, wireless, through an Apple Airport Extreme/Express.
     
  24. macrumors 6502a

    #24
    Powering down / powering up the NAS does not remove the problem as it must be some sort of persistent file...

    The NAS is hard-wired to my home network...
     
  25. switon, Dec 7, 2012
    Last edited: Dec 7, 2012

    macrumors 6502a

    #25
    RE: Wow!...

    Hi JoelBC, (is that British Columbia or Boston College or ?)

    Wow! What problems you have...

    Did you try forcing the unmounting of the shared drive? If someone else has a connection to the drive, then you will not be allowed to unmount it. I believe that forcing (-f) the unmounting will unmount even when others are connected.

    Do you have a launch agent or daemon that is continuously mounting this share?

    Is this share being mounted by more than one protocol, say afp, smb, and/or nfs? Are you allowing "Guest" SMB connections? Are any of your "neighbors" connecting as Guests?

    Are you running Mac OS X Server? If so, could you execute the following command to see what users are connected to the share:

    serveradmin command afp:command = getConnectedUsers

    Switon
     

Share This Page