USB Flash Drive random disconnection

Discussion in 'Mac Help/Tips' started by orangefoodie, Mar 4, 2003.

  1. orangefoodie macrumors member

    Joined:
    Jan 17, 2003
    Location:
    Entirely TOO FLAT Ann Arbor, MI
    #1
    Dear folks,

    As a potential switcher (Still waiting to see that 17 inch pb with my own eyes :D) I have this following problem that I've noticed when using the macs at the Umich Fishbowl (the giant computing centre).
    I have this little USB Flash drive doohickey, with a capacity of 128 megs - and I plug it into the other USB slot on the keyboard. It works fine and dandy, and switches between Macs and PC's effortlessly. The problem is, the computer thinks I've pulled the plug on it without ejecting the drive image after a period of inactivity in the drive, giving me a message of "This drive was not removed properly. Yada yada." and then my disk is nowhere to be found. I have to then unplug it then replug it in for the system to notice it's actually there again and remount the disk.

    So, the question is, has anyone else used similar USB flash drives on OS X? The systems I've tried it on run OS 10.2.3 on a 566 Pmac - is there any reason for this unexplained disconnection? The thing works fine on PC's... And, is there a solution? I'd really like to have it mounted on the computer regardless of whether it's been idle for 10 minutes or 10 hours...

    Thanks in advance!
     
  2. timbloom macrumors 6502a

    timbloom

    Joined:
    Jan 19, 2002
    #2
    I might think that going into energysaver and turning off "put inactive disks to sleep". It might just be that it is sending it some kind of instruction to sleep, and it is just unmounting itself.
    For a permenant fix, I have no advice, but tell me if this works for you for now.
     

Share This Page