USB Mass Storage Device Driver Not Found

Discussion in 'Windows, Linux & Others on the Mac' started by sixth, Mar 21, 2007.

  1. sixth macrumors 6502

    Joined:
    Aug 16, 2006
    #1
    Guys...

    I am running Vista Ulimate. This is blowing my mind. I have two USB memory sticks. One is a Sandisk and the other is a Kingmax. The Sandisk works fine, the Kingmax can not find the correct mass storage driver anywhere. I have tried everything that I can think of and did tons of google searching so I am assuming this is a MBP issue. I even tried forcing another driver, looking at how the driver is on the sandisk card etc. How can one work and not the other!!!!
     
  2. OwlsAndApples macrumors 6502a

    OwlsAndApples

    Joined:
    Oct 4, 2006
    Location:
    UK
    #2
    Maybe Vista's trying to use it as extra RAM secretly :rolleyes:

    If google fails thee...suffer? :eek:
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    There should be a generic driver for a USB Mass Storage device. There is in Windows XP at least.
     
  4. sixth thread starter macrumors 6502

    Joined:
    Aug 16, 2006
    #4
    yeah...there SHOULD BE a universal driver. vista is being so stupid with this...i just tried another usb stick and it doesnt work. tried my boss's and it works...

    freakin stupid!!
     
  5. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #5
    Have you plugged it in and then told Windows to use the generic USB mass storage driver?
     
  6. sixth thread starter macrumors 6502

    Joined:
    Aug 16, 2006
    #6
    where is that driver located at? i looked in windows/system32/drivers and couldnt find one to use??
     
  7. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #7
    You'll have to manually pick it when you go through the "Add Hardware" process. You start off with an Unknown device and then you assign it to be a Mass Storage Device. I've had to do it myself when XP couldn't find the driver itself for a USB flash memory drive.
     
  8. sixth thread starter macrumors 6502

    Joined:
    Aug 16, 2006
  9. sixth thread starter macrumors 6502

    Joined:
    Aug 16, 2006
    #9
    i think my whole vista install is messed up..i still have four unknown devices..here they are..

    1. Other device on UMBus Enumerator
    2. 3 Other device on USB Human Interface Deivce (no idea why these are unknown but they cant find a driver no matter what I do.
    3. I also have 3x Apple Bluetooth radios as unknown devices even though the Apple Bluetooth radio was successfully installed..crazy.

    Should i install some sort of Intel Chipset controller drivers to fix this? I mean I cant figure it out. My whole driver scheme is messed up i think. :-(
     

Share This Page