USB2 Wifi only getting 36mb/s?

Discussion in 'PowerPC Macs' started by orestes1984, Sep 29, 2012.

  1. orestes1984, Sep 29, 2012
    Last edited: Sep 29, 2012

    macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #1
    So I bought a USB2 Wifi adapter and it only gets 36mb/s :mad:

    [​IMG]

    It's effectively useless at these speeds, it means I can't use it with my Apple TV at all... What's going on? It's supposed to be 802.11n...

    [​IMG]

    Clearly its not, I thought USB2 was supposed to be 480mbit a second I should be able to do 802.11n with USB2. Is there anyway to force 802.11n on a Mac?
     
  2. macrumors 6502

    chibiterasu

    Joined:
    Apr 5, 2012
    Location:
    London, The United Kingdom
    #2
    USB 2.0 is rated 480*Mbit/s (60*MB/s) per controller and is shared amongst all attached devices.
    Although typical hi-speed USB devices can be written to at rates around 25–30*MB/s, and read from at rates of 30–42*MB/s, according to routine testing done by CNet. So you getting around 36 MB/s which is a read speed is about what you should be expecting and there is nothing wrong with your mac or USB wifi adaptor. Hopes this helps :)
     
  3. orestes1984, Sep 29, 2012
    Last edited: Sep 29, 2012

    thread starter macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #3
    Thanks... I screwed up my calculation, that seems about right... I've got it playing now without stuttering.
     
  4. macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #4
    According to your second screenshot you are using WEP. Aside from WEP being more or less the same thing as no protection at all, the maximum transfer rate for 802.11n using WEP authentication is 54 Mbps as specified in the IEEE 802.11n standard. (Related reading)

    No. USB WiFi and USB mass storage are not quite the same. The link speed most definitively is not 36 MB/s. Believe it or not, the label says "Mbit" for a reason.
     
  5. thread starter macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #5
    I didn't realise WEP would limit traffic like that... I realise its not secure, but I don't live in an area where I'm likely to get hacked and I was just testing this to make sure it worked. eBay purchases are very hit and miss.

    Anyway, it's now running WPA2 and is running much faster, thank you :)
     
  6. macrumors 6502

    skateny

    Joined:
    Jul 19, 2012
    Location:
    New York, NY
    #6
    I use the same dongle (my AP Extreme kept forcing kernel panics), and I typically get 52MB/s.
     
  7. macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #7
    You're welcome, glad it worked out.

    Sure you're not getting 52 megabit/s? Sounds far more reasonable than 52 megabyte/s... ;)
     
  8. macrumors 6502

    skateny

    Joined:
    Jul 19, 2012
    Location:
    New York, NY
    #8
    True. My bad.
     
  9. macrumors member

    PerformaGuy

    Joined:
    Oct 5, 2012
    #9
    Hi there,

    That looks to be 36 Mbps, as in 36 megabit/s not 36 megabyte/s.

    Most cable ISPs have a 15-25 megabit/s rating.
    DSL is even slower around 6-10 megabit/s.

    Unless you have fiber to the home (like Verizon Fios which is 50 megabit/s I believe), you probably won't notice a difference.

    May I suggest to use your internal AirPort card and run a bandwidth test on http://www.bandwidthplace.com for example.
     
  10. macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #10
    Yes, you are completely right. Definitively megabit. Like the OP actually wrote, and that I've already pointed out to the ones confusing the units. :)

    Unless of course you want to communicate locally, like streaming from a computer to an AppleTV just like the OP wanted. In that case you will notice a difference...

    I'm tempted to ask if you actually bothered to read the thread, but that would probably sound hostile and somewhat rude, so I won't. :p
     
  11. thread starter macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #11
    I've rewired my network to the Apple TV. The server is now using the Wifi to call home to the mothership and I've gone via CAT5 to the Apple TV. I'm now running internet connection sharing on the server which is doing routing to the Apple TV. Caching is now occuring over a LAN rather than a WAN connection and the speeds are much improved.

    At 100mbit/s I can now cache a movie on the local server to my Apple TV in a matter of minutes.
     

Share This Page