Use Siri to Send a Message via iMessage

Discussion in 'iPhone' started by NightFox, Oct 17, 2011.

  1. macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #1
    If I tell Siri to send a message to one of my contacts, it will send a text message (SMS) to their mobile number if one is listed. If there's no mobile number, it will send an iMessage if they have an iMessage account.

    So, for example my daughters both have iPod Touches and my older daughter also has a mobile phone. If I send a message to them both, eldest gets an SMS on her mobile, youngest gets an iMessage on her iPod.

    However, I'd prefer the option to be able to specifically send an iMessage or at least use iMessage in preference to SMS, but their doesn't seem to be a way. Siri even understands if I say "send an iMessage to..." but it still sends an SMS rather than an iMessage if I have a mobile number for that person.

    Anyone found a workaround?
     
  2. macrumors member

    Joined:
    Jul 20, 2010
    Location:
    Warwickshire, UK
    #2
    Hi Nightfox,

    I am not sure why you are having issues here.

    Regardless of whether you use Siri or type the message, if the recipient is on iMessage, it will send it as such. If iMessage is unavailable, then it will send a text. I have tried it several times and it always sends an iMessage if the service is available

    Obviously, for your daughters iPod, this does not have a phone number so can only receive iMessage via an email address.

    It can only send an iMessage to a phone number is that phone is an iPhone running iOS5.

    I hope this helps and apologies if any of it sounds patronising, its not meant to.

    Jason
     
  3. thread starter macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #3
    Interesting - quite the opposite happens for me; it only ever sends as iMessage if there's no mobile number stored. If I delete my daughter's mobile number from my contacts, it'll send an iMessage to her iPod. However, if I add her mobile number back, it sends an SMS to her Nokia instead.

    It looks like it takes a preference from somewhere and you've got yours set different from mine; just wish I could work out how it's set and how to change it!
     
  4. macrumors regular

    Joined:
    Mar 11, 2011
    Location:
    Hull, UK
    #4
    As a temporary fix you could list her iMessage email and her phone number as separate contacts. For example you could add iPod onto the end of her name for iMessage.
     
  5. macrumors member

    Joined:
    Jul 20, 2010
    Location:
    Warwickshire, UK
    #5
    The clue might be the Nokia, it only works on iPhones.

    Jason
     
  6. macrumors 68020

    Joined:
    Sep 3, 2009
    #6
    Yea, this solution would be your best bet.

    Mel
     
  7. macrumors 6502a

    Joined:
    Sep 19, 2008
    #7
    If the device your are sending a message to and from is an iDevice and is running ios5, it'll send as an iMessage. Even if you send the Message to her phone number and that phone number is associated as an iPhone running ios5, it'll still send as an iMessage. If you send an SMS to a non iDevice, it'll send as an SMS.
     
  8. NightFox, Oct 18, 2011
    Last edited: Oct 18, 2011

    thread starter macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #8
    I think you misread my post - I'm not expecting it to send an iMessage to her Nokia, I mean it sends a txt to her Nokia instead of an iMessage to her iPod.
     
  9. thread starter macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #9
    But my scenario is that her contact details include a mobile phone number (her Nokia) and an email address (registered as an iMessage account on her iPod). If I manually use the Messages app, I can chose whether to send the message to her mobile number or her email address (I don't mean just sending her an email). If I choose the mobile number, a txt will get sent to her Nokia; if I choose email address, an iMessage will get sent to her iPod. If you're an iPhone user, you may not be aware that you can assign email addresses to your iMessage account as well as your iPhone number, obviously this is the only thing you can use on an iPod as it doesn't have a phone number!

    However, my original question is if I use Siri, it doesn't give me this option. It just automatically uses her mobile number and sends a txt to her Nokia so I can't send an iMessage to her iPod using Siri. To my mind it should work like when you have more than one phone number for a contact; ask Siri to phone them and it will ask you which number you want to use. When I tell Siri to send a message to my daughter, it should ask whether to use her mobile number or her email address.
     
  10. macrumors 68020

    Hankster

    Joined:
    Jan 30, 2008
    Location:
    Washington DC
    #10
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Your iMessage goes to her iPod because it's an iPod. IMessage cannot go to a Nokia phone. They only go to other iOS devices.
     
  11. thread starter macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #11
    Sorry, this still isn't what I'm saying! I'm not expecting an iMessage to go to her Nokia. I want to send an iMessage to her iPod, but Siri always sends an SMS to her Nokia instead; it doesn't give me the option.
     
  12. macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #12
    I think you're going to need to split it into two separate contacts - one with just the email, one with just the phone number.

    I think the iPhone will always attempt to message a number first, regardless of whether it has iMessage or not, before it attempts to use email.

    That's probably the way it should be, too.

    In Settings > Messages you could disable "Send As SMS", but that will stop you texting anyone that doesn't have iMessage.
     
  13. thread starter macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #13
    Done a bit of playing around and it seems that Siri defaults to the last manually used method, i.e. if I send my daughter a text 'by hand' and then I ask Siri to send her a message, it will send a txt to her Nokia. However, if I then send an iMessage to her iPod and ask Siri to send her a message, it will iMessage her iPod.

    Good that it means that it can do both, not so good that I have to remember what I last sent to be able to predict where Siri will send it! Yes, as miniConvert said I could create two contacts, but I do hate workarounds, especially on Apple 'it just works' stuff, so I'll live with it for now. Guess I'll just have to speak to her instead. ;)
     
  14. macrumors newbie

    Joined:
    Oct 18, 2011
    Location:
    East & West
    #14
    I'm with you NightFox, and understand the problem here. My wife has an iPad and a non Apple mobile phone. No matter what I do, if I tell Siri to send a message to my wife, Siri sends an SMS. I can manually send an iMessage to my wife. Siri knows the word "iMessage", but doesn't obey when told to send an iMessage.
     
  15. macrumors 6502a

    Joined:
    Jun 11, 2011
    #15
    You can send an iMessage based on the person's e-mail associated with their Apple ID. Someone I know sent me a message using my e-mail and it showed up coming from their e-mail until I added them to contacts. Maybe that will work?
     
  16. thread starter macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #16
    That's how I manually send an iMessage (to my daughter's email address) as that's the only way you can set up iMessage on an iPod/iPad as they don't have phone numbers associated with them. The point is, when you ask Siri to send a message (or even and iMessage) to someone, if there's a mobile phone number and an email address for them in your contact list, it doesn't ask you which you want to use. This is fine if they're both associated with the same iMessage account, but if the mobile number is for a non-Apple mobile phone it is a pain.

    ----------

    Did you try what worked for me? Send her an iMessage (by hand, not with Siri) and then try it with Siri. For me Siri defaulted to the last used method.
     
  17. macrumors regular

    Joined:
    Sep 20, 2011
    Location:
    Lexington, KY
    #17
    Nightfox, I know you are getting all kinds of confusing replies from people who didn't bother to read what you wrote. A truly annoying feature of the internet.

    Here is a suggestion of why you have this problem. iMessage tries to deliver the message first and if it can't it sends a regular text message instead. The receiving idevice must have ios5 and have a WiFi connection since iMessages are not sent over the cellular network. If your daughter is not attached to WiFi at the time you send the message, it takes the second alternative and sends a regular text to the phone number (in this case the Nokia phone). You could test that theory by trying an iMessage while you know for certain your daughter is attached to a WiFi signal with her iPod.

    If there is no alternative (no phone number) as in the case of your other daughter, then the system holds the iMessage until the recipient attaches to WiFi.

    If I'm correct all you will need to do is separate your daughter's contact address into two so the mobile phone is not an alternative message receipient.
     
  18. macrumors newbie

    Joined:
    Oct 18, 2011
    Location:
    East & West
    #18
    Thanks, that seems to be exactly how it works. If my wife's iPad is off or sleeping, Siri sends the message as a text/SMS. If the iPad is on and connected to WiFi Siri sends the message using iMessage. Separating the contact into two entries appears to be the only fix until Siri learns what "send an iMessage" means.
     
  19. macrumors 6502a

    bigred7078

    Joined:
    May 6, 2010
    Location:
    North Carolina
    #19
    I have nothing to contribute other than I share in the OP's frustration with the people who don't understand what he is asking lol...
     
  20. macrumors newbie

    Joined:
    Oct 27, 2011
    #20
    NightFox - try this

    This is not thoroughly tested but I had the same problem and I agree that if Siri asked which number or email to send a message great, but it doesn't so...
    Look in your Address Book and see how your daughters email address is listed. If it is Home (work, etc) then tell Siri to "Send message to daughter home" and it will iMessage rather than text mobil number.
     
  21. Gordonw, Oct 27, 2011
    Last edited: Oct 27, 2011

    macrumors member

    Joined:
    Oct 9, 2011
    #21
    You can send an iMessage to your daughters iPod, but you have to tell Siri in a specific manner. Siri will always send message to a mobile number so first thing you need to do is check your daughter's contact info in your contact app. Your daughter's mobile number should probably be listed in the mobile field. As for her Apple I.D. associated with her iPod which is her email address should be listed in the home field.
    In order to iMessage your daughter on her iPod, you should say "send a message to <daughter's name> home, or home address, or home email address.
    This worked for me in iMessaging to an iPad.
     
  22. macrumors newbie

    Joined:
    Nov 10, 2011
    #22
    Settings can prevent Siri defaulting to SMS

    Siri does distinguish between message and iMessage. If you say send an iMessage and the recipient is an os5 user and is connected to wifi, Siri will send via iMessage. If they are not an os5 user, or not connected to wifi, the send defaults to SMS.

    You can prevent sending SMS by changing the settings. Go to Settings, Messages, and turn 'Send As SMS' to OFF. The downside is that off is off for all messaging. I don't know any other workaround that will prevent SMS when iMessaging isn't availabile for the recipient.
     
  23. macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #23
    That's what the Tips, Help and Troubleshooting forum is for. The replies in there are 100x better since the people posting in that forum are there to help. Take note, and use the correct forum when creating a post, and you won't get (as many) crappy replies.

    OP, the reason this is happening is very simple: the messaging app is set up to primarily handle mobile-to-mobile messaging, so it is going to prioritize on this. That is to say, Siri and the messages app is going to choose the phone number over the email address unless you tell it to send to the email address. Since the mobile number is not another iOS 5 device, then naturally the message will be a text and not an iMessage. The advice to set up under two contacts is solid, or you can fiddle around with telling siri to direct the message to the email address (although I'm not certain that's possible).
     
  24. macrumors 68030

    Joined:
    Nov 13, 2011
    Location:
    UK
    #24
    OP I share your frustration on not being understood. I stopped reading after the poster who said


    My son has an iPod. I iMessage him. He isn't on wifi. The iMessage does not change to an SMS like it should and send to his android mobile phone. Before anyone says it shouldn't. That's not what it says in the iPhone manual or in the iPhone message settings. It says when iMessage is not available it will send as SMS. And a phone number is associated with his contact on my phone so it should change to SMS. It should try to send the iMessage , time out , send as SMS instead. It doesn't.

    If I send another text as SMS it doesn't combine the two chats like it should. I end up with 2 separate conversations. A blue iMessage and a green SMS both with his name.

    So why doesn't iMessage understand the contact details and combine the chats?

    I think this is also why the OP is having problems because Siri should be first trying iMessage, timing out, send as SMS.
     

Share This Page