using arrow keys to scroll

Discussion in 'Mac Basics and Help' started by CrzyCanuck72, Jan 4, 2007.

  1. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #1
    Is there any way to use the arrow keys to scroll vertically (especially in Firefox)? I'd like it to smooth-scroll, instead of scrolling a page at a time...right now in Firefox, pressing the down arrow jumps to the bottom of the page (and the up arrow apparently doesn't do anything). I realize I could use the trackpad to scroll, but I'd love to just be able to hold down the arrow key.

    TIA
     
  2. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #2
    The arrow keys do smooth scroll for me in Firefox. It's a little jerky, but it doesn't jump all the way to the bottom of the page unless I use fn+right arrow to activate "end" on my PowerBook.
     
  3. PYR0M310N macrumors 6502a

    PYR0M310N

    Joined:
    Aug 29, 2006
  4. CrzyCanuck72 thread starter macrumors 6502a

    Joined:
    Jun 10, 2003
    #4
    weird now it's working for me...but it looks like it's jumping down each line of text (ie. I can see the cursor skipping down each row)...is that just the way it works?
     
  5. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #5
    Yep, that's pretty much just how it works. Firefox has a pretty small increment and thus looks fairly fluid. Safari's increment is a bit larger.
     
  6. CrzyCanuck72 thread starter macrumors 6502a

    Joined:
    Jun 10, 2003
    #6
    yeah, the scrolling is fluid but the jumping cursor is a bit distracting...oh well, thanks!
     
  7. tigerlight macrumors newbie

    Joined:
    Dec 9, 2008
    #7
    figured it out for Firefox

    I had the same problem using Firefox. up/down arrow keys controlled the cursor. So when I was at the bottom of text is appeared to scroll correctly but if I was somewhere else on the page it jumped.

    In Firefox Preferences,
    click Advanced,
    click the General tab,
    in the Accessibility section uncheck "Always use the cursor keys to navigate within pages".

    I also checked "use smoothing scrolling".
     

Share This Page