Using Terminal to write programs, not allowing me to access the university's servers?

Discussion in 'Mac Programming' started by smokeybear, Jan 31, 2013.

  1. macrumors newbie

    Joined:
    Jan 30, 2013
    #1
    Hey guys I have a couple questions. I took my first lab for my Computer Science class. We're getting into writing code and getting used to a Unix system.

    Their computers are Windows 7 OS based: So we used the programs PuTTy, which the TA let us know that the equivalent would be Terminal in Mac.
    Using PuTTy we accessed the university servers, and it prompted us to write in the server we're going to use (cse01.cse.unt.edu). PuTTy then brought up the command line, further prompted me to type in my login, followed by password.

    In Terminal, I ran into a speed bump. The TA informed us on Mac, Terminal is PuTTy's equivalent. At this point, I'm unsure as to how I provide my login name to the university servers ... the screenshot should provide a better visual example.

    Any ideas?

    (Also an additional, slightly less complicated, question, I like to change my preferences to the Homebrew theme, but it doesn't seem to want to save my preferences and reverts back to basic black and white, default theme. Anyone know how to save my preferences in Terminal?)
     

    Attached Files:

  2. macrumors 68040

    lee1210

    Joined:
    Jan 10, 2005
    Location:
    Dallas, TX
    #2
    ssh yourusername@cse01.cse.unt.edu

    Unless your OS X username was the same as the username provided for use on the university's systems, you can't SSH without providing the username.

    Then you'll be prompted to enter your password.

    I'd look into setting up a shared key so you have less to type, but don't worry about that for now.

    If you choose vi(m) for an editor, print something like this:
    http://www.tuxfiles.org/linuxhelp/vimcheat.html

    Good luck.

    -Lee
     
  3. macrumors regular

    Joined:
    Aug 21, 2011
    Location:
    Stockholm Sweden
    #3
    ssh, not terminal

    Perhaps a bit nit-picking, but some of find this to be an important difference.

    The program you use to acces the university servers is ssh.
    You start the program on OSX from terminal (which happens to be another program).

    In windows, the ssh function is not builtin so you need to add some program.

    On OSX it is not needed, but if you whish to you can get the program JellyFiSSH instead of using ssh directly.

    // Gunnar
     
  4. LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    Go to Terminal-->Preferences and click on Startup. Click on the button for "New window with settings:" and select Homebrew from the menu. Then quit Terminal and reopen it.

    If that doesn't work, I'd probably delete the Terminal .plist file.
     
  5. macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #5
    Click on Terminal -> Preferences. Choose the Settings tab, then highlight the theme you want and click the "Default" button beneath the list. If there's anything you dislike about the theme, there's plenty of things you can change to the right of it. Personally, I like "Pro"... good contrast and less... eye-burning when you're working in a dark room / bus / plane...
     

Share This Page