utilities problem

Discussion in 'Mac Apps and Mac App Store' started by lazyboy922, Feb 27, 2004.

  1. lazyboy922 macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #1
    when i try to run terminal, the program seems to be open, but the window will not show up. It's just a little red circle (the ones on the bar to close the window) and thats all. Anyone ever have this problem?
     
  2. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
  3. lazyboy922 thread starter macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #3
    oops i meant to say terminal!!!!!!!!!!! sorry for the typo!
     
  4. janey macrumors 603

    janey

    Joined:
    Dec 20, 2002
    Location:
    sunny los angeles
    #4
    maybe your window is completely transparent or its like an insanely small size. Play around with preferences, but before you do that, open a new window and see if you have the same problem.
     
  5. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #5
    yah..may be a problem with theh window size. open terminal. from the top menu, click terminal-windowsettings. from the drop down menu select window. There give the columns as 80, rows as 24. press tab, click use settings as default..see what happens ;)
     
  6. lazyboy922 thread starter macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #6
    Hmmm, i tried all of those things, and it didn't work. I don't get it. the window is just the small red circle, and a tiny border around it.
     
  7. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #7
    Try going to Home/Library/Preferences and deleting com.apple.Terminal.plist.
     
  8. raytube macrumors member

    Joined:
    Nov 13, 2003
    Location:
    Scotland
    #8
    Hi,
    Have you removed any fonts from your system? I encountered this problem when I had some fonts disabled, I think it looks for the font Monaco by default for terminal.

    Cheers,

    Rick
     
  9. lazyboy922 thread starter macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #9
    hex monkey, it seems i do not have that file? and I also do not have the monaco font. could this be my problem?
     
  10. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #10
    Are you sure the file isn't there? Did you look in the right Library (There is a Library at root level, but there is another in each user folder. You should be looking in the Library in your user folder)? It seems old that it wouldn't be there. It basically just stores a few Terminal settings, but not being there is not really a problem.

    As for the font, Monaco is the default viewing font for Terminal, but I wouldn't think it would be the cause of the problem. In Terminal, go to the Font menu, select Show Fonts, and select a different font if that hasn't been done already.
     
  11. lazyboy922 thread starter macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #11
    ah yes, i was in the wrong library, however, i deleted it and it still didnt work. should i use my software restore disk or something? ive already tried to repair permissions and no luck there either.
     
  12. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #12
    Try changing the font if you haven't already, just in case this is the problem (make sure you reopen Terminal after making the changes to make sure you know if it has worked or not). Failing that, try creating another user and see if the problem occurs there. That will narrow down the source of the problem.
     
  13. raytube macrumors member

    Joined:
    Nov 13, 2003
    Location:
    Scotland
    #13
    Hi,
    Yep, definitely check that you haven't disabled any fonts using Font book or whatever. That's what had happened when I encountered the same thing the other day.

    You can check it by going in to Window settings (under Terminal) and selecting the 'Display' option on the popup menu. If the 'Text' field displays any gobbledegook, or a strange name and/or a weird pt size for the text then that's your problem. The font is missing.

    The default is Monaco Regular 10pt.

    Hope that helps!

    Edit:
    Also, you may find that trying to change the font to something else doesn't work, neither changing the font name or the size was possible when I encountered this, I had to enable the Monaco font before it worked. Kind of a glitch there I guess.

    Cheers,

    Rick
     
  14. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #14
    I think you misinterpreted the suggestion. Terminal uses Monaco so the idea was to put it back if it was missing. Do you still have it somewhere?
     
  15. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #15
    Yep, it's definitely the Monaco (or whatever you chose as default) font is disabled.
     
  16. lazyboy922 thread starter macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #16
    ok, i must have deleted monaco somehow, is it on the software restore cd? and yes that is the problem because the font in the terminal preferences is different as suggested. however, it wont let me change the font. I choose to set as default or whatever it specifically says, and it will not change the font. I guess i will just have to keep playing with it or try to find monaco. thanks for your help guys.
     
  17. lazyboy922 thread starter macrumors 6502

    lazyboy922

    Joined:
    Dec 9, 2003
    Location:
    Las Vegas, NV
    #17
    Thanks for the email with the monaco font! it totally resolved the problem!
     

Share This Page