Valve Games (HL2, TF2..) crashing on Macbook Aluminium via Bootcamp!

Discussion in 'Windows, Linux & Others on the Mac' started by Aleksian, Jan 28, 2009.

  1. macrumors newbie

    Joined:
    Jan 28, 2009
    #1
    Hi!
    I've recently installed the Orange Box on my Aluminium 13" Macbook (2.4Ghz).
    At first, the games ran fine, but soon I started experiencing a lot of crashes (happened with HL2, HL2 Episode 1, Team Fortress 2, (haven't tried the others)). Sometimes the game just freezes (i hear a repeating sound), then quits. I get different error messages every time:
    "The instruction at '0x0######' referenced memory at '0x#####'. The memory could not be 'written'"
    or
    "This application has encountered a problem and needs to close."
    but sometimes I don't get any message (the game just quits).
    Turning down the graphics settings to "low" didn't help.
    I tired disabling the background programs but that didn't help either.

    I would appreciate your help!:D
    Thanks in advance;).
     
  2. Guest

    Joined:
    Nov 6, 2007
    Location:
    Italy
    #2
    I believe there has been an NVidia driver update for Windows, have you heard about it? Have you updated?
     
  3. thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #3
    Unfortunately I haven't updated the graphics driver because I haven't been able to find one. :( I checked the Nvidia website for the 9400M drivers but i couldn't find any, so I Googled GeForce 9400M XP driver and also couldn't find a proper update.
    I tried updating with the Hardware Manager (in Control Panel) but it didn't find any new drivers. I have the 176.44 driver version (the one that came with BootCamp).
     
  4. macrumors 65816

    FX120

    Joined:
    May 18, 2007
  5. macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #5
    Laptopvideo2go has a good nvidia driver I think.
     
  6. macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #6
    that website is a bit confusing.. where to go for a 9400m?
     
  7. macrumors 6502a

    Joined:
    Sep 23, 2007
    #7
    Download any of the drivers there and FOLLOW THE INSTRUCTIONS.

    However, it appears that Nvidia just recently added support to their mobile video cards. HOWEVER, the 9400M GS is NOT supported in the list of supported GPUs, so use laptopvideo2go.

    I would get your driver here:

    http://www.laptopvideo2go.com/forum/index.php?showtopic=22323

    FOLLOW THE INSTRUCTIONS. Everything you need is in the first post.
     
  8. macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #8
    I see thanks, and if I plan on running the 64 bit Vista, I would obviously get the same driver 179.28 in 64bit.. would that be the best choice in terms of vista 64
     
  9. macrumors 65816

    FX120

    Joined:
    May 18, 2007
    #9
    It's a beta version of the drivers, so I can't say.

    Anyway, nVidia has a unified driver architecture, meaning the drivers are not usually card specific. The latest GeForce drivers will generally work on any card ranging from the absolute latest and greatest card, back to the GeForce 3 series.
     
  10. thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #10
    Thanks for your answers:D, but unfortunately the problem remains.
    I tried downloading and updating the driver form Nvidia ( http://www.nvidia.com/object/geforce...9.28_beta.html) but it said my graphics card was not supported (as expected).
    Then I tried installing the driver form http://www.laptopvideo2go.com/forum/...howtopic=22323 .
    I first downloaded the driver itself and it installed successfully (without the Modded INF), but it installed the driver for GeForce 8400M, because the 9400M in not supported (not listed). I tried running HL2 with that driver but I got the same crash.:(.
    I rolled back to my default driver (the one that came with BootCamp) and pasted the modded INF (from laptopvideo2go) over the one in the driver folder I downloaded previously (from laptopvideo2go). But when I tried installing it with the Have Disk option it said: "An error has occurred during the installation of the device. The driver selected for this device does not support Windows XP" (on laptopvideo2go it says the driver is for XP)

    I hope you understand what I've just written :D :D.
    Thanks
     
  11. macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #11
    okay I ended up running XP on my alu macbook I got setup today so I'm looking for an updated driver for the 9400m; so I'm in the same boat as the OP. help?
     
  12. thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #12
    Ok, I've had some progress :D.
    I didn't get any proper results Googling and searching for GeForce 9400M XP driver, but I discovered the codename for the GeForce 9400M (http://www.notebookcheck.net/NVIDIA-GeForce-9400M-G.11949.0.html). Apparently it's also called MCP79MX. So I Googled for MCP79MX XP driver and got this forceware driver: http://www.laptopvideo2go.com/drivers/xp/174.60 . It says the original INF supports the MCP79MX (GF 9400M) so I'm guessing it should be ok. I haven't tried installing the driver yet.
    What do you think, should I try? :eek:
     
  13. thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #13
  14. macrumors 6502a

    Joined:
    Sep 23, 2007
    #14
    Yeah... I'm assuming the "have a disk" option is through the device manager. When you put in the new inf file, you just re-run the driver setup (the setup.exe). You shouldn't have to go through the device manager.

    Anyway....

    Just keep trying drivers. Many of those drivers were never intended for laptop/mobile use, so people encounter problems. Just read some of the comments to determine if it's worth your effort or not.
     
  15. macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #15
    I have a 2.0 alu stock everything except HDD. Anyway, I'm using ALL boot camp 2.1 drivers, nothing special, even the nVidia drivers aren't anything I modified. Anyway I just installed Orange Box retail disc via steam and I played HL2 for 2 hours last night no problems. XP SP3 TinyXP edition. So I dunno, try using the boot camp driver for the nvidia?
     
  16. thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #16
    Ok so neither of the drivers worked :(. The game still crashes. It used to be fine at the beginning of the game, but towards the end it just keeps crashing. I don't know what to do anymore :(...I've just unistalled everything Steam/Valve related, so I'll try reinstalling the games.
     
  17. macrumors 6502a

    Joined:
    Apr 12, 2008
    #17
    Nvidia now supports the 9400M, so give them a try. :)

    http://www.nvidia.com/object/notebook_drivers.html
     
  18. macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #18

Share This Page