Ventrilo for Mac (WoW)

Discussion in 'Games' started by mikeyPotg, Jan 12, 2007.

  1. mikeyPotg macrumors 6502

    Joined:
    Mar 20, 2006
    #1
    Hello, I used to play WoW in June and my mac vent client worked well, however I just got back into WoW and downloaded the new "prototype" client and it doesn't work well. It installs and I can log on and see the people, but I never hear anyone talking. I see the mics go green when someone should be talking and I hear "so & so has entered the room" but no one talking.

    Has anyone had similar issues?
     
  2. iMacMike macrumors newbie

    Joined:
    Jan 12, 2007
    #2
    You need some USB headphones...

    I have an older 17 inch iMac that I am using WOW on - and I too downloaded Vent. I tried everything and came up with the same kind of results.

    What you need to do is invest in a pair of USB headphones with a built-in mic. Do NOT buy just a regular pair - get USB ones. They are worth every penny (should be able to get one for around $40 US).

    Plug those in and go into the settings in Vent and make sure to switch both your input and output sources to the new headphones. You should be good to go. Whenever I play WOW I just plug the headphones back in - when I do other things I unplug them - though you could certainly still use them for iTunes, etc.

    Oh - one other thing - do not plug them into the USB port on your keyboard - it will overload it :)

    Regards,
    iMacMike
     
  3. mikeyPotg thread starter macrumors 6502

    Joined:
    Mar 20, 2006
    #3
    Hey, thanks a lot, I appreciate that. I'll certainly look into a USB headphone, though I was hoping I'd be able to play/raid with my speakers. No biggie, I'll see how it goes.
    Thanks again!
    Mike

     
  4. robbents99 macrumors regular

    robbents99

    Joined:
    Jan 15, 2001
    Location:
    Directly under the sun....now.
    #4
    I just downloaded Ventrilo tonight, what server do I use for WOW?
     

Share This Page