Very slow "contacting / looking up" websites in firefox & safari - help!

Discussion in 'Mac Apps and Mac App Store' started by Megatron, Dec 22, 2005.

  1. Megatron macrumors regular

    Joined:
    Nov 19, 2005
    #1
    Hi, I have the latest rev 12" ibook that works like a charm. At my apartment, I have cable internet and use a 54G router, and airport works flawlessly, pages load fast, etc.

    Whenever I use my ibook at my parent's house (also has cable) it takes several seconds in the "looking up / contacting" stage (in either firefox or safari) whenever I try to go to a new page. These are big pages like cnn, google, nytimes, etc.

    It's fine once I'm on a page and browsing (as long as I stay in that domain) but if I let it sit for a while and then try to reload, it has to do it's contact / lookup again.

    The connection is super fast on all the wired computers, and on PC wireless laptops.

    Does anyone have any idea what could cause this slowdown? Could it be whatever type of encryption is being used?

    Thanks - I'm at a loss! :(
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    I know it's fine on the other PC laptops, but have you tried resetting your router? Unplug it and leave it for half a minute, plug it back in again and see if that helps. It's worth a try. :)
     
  3. Megatron thread starter macrumors regular

    Joined:
    Nov 19, 2005
    #3
    After various resets in the past I haven't noticed an improvement in the speed, unfortunately.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Sounds to me like the DNS records on your Mac are corrupt somehow. Bad DNS = long delay before it figures out those DNS servers don't exist and finds the right ones.

    To fix this, check one of the working machines DNS server settings and change yours to match.
     
  5. Megatron thread starter macrumors regular

    Joined:
    Nov 19, 2005
    #5
    Yes that makes sense - I was thinking it had to do with the DNS stuff - but how do I fix that on my mac? I thought everything was automatic? Is there a setting somewhere?

    Forgive me, this is my first mac and i'm not very familiar with the network settings.
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    Go to System Preferences, then Network, pull down the Show menu and choose AirPort, click the TCP/IP tab, look at DNS Servers text box. That's the one.
     
  7. Megatron thread starter macrumors regular

    Joined:
    Nov 19, 2005
    #7
    Ok, I checked that textbox and it is blank. Should there be something there?
     
  8. Megatron thread starter macrumors regular

    Joined:
    Nov 19, 2005
    #8
    I fixed it!

    I entered the primary, secondary, and tertiary DNS servers listed for my ISP in the DNS field and that fixed it. Now everything is fast!

    I guess I just thought you could get that information from the router when you use dhcp to get your IP address, but I guess not?
     

Share This Page