Very smallll Terminal window

Discussion in 'Mac Apps and Mac App Store' started by Bakey, Feb 15, 2005.

  1. Bakey macrumors 6502

    Joined:
    Oct 6, 2003
    Location:
    O Donny Boy
    #1
    Hi!!

    I'm trying to use the Terminal, but unfortunately the windows which open-up are simply unusable. They're so small I can't even grab the drag handles...

    Is there are way of returning them to their default size by means of a file delete/hack? I don't even know how this has occured; it "just" happended!!

    Happily running Panther.8 on a G3 iMac with 512meg... many thanks in advance ;)
     
  2. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #2
    Try hitting [Apple]-m. I think that is the key command, at least it changes from windowed to full screen mode in games.
     
  3. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #3
    Command (or Apple)-m usually minimises a window. If you are willing to remove ALL your Terminal.app preferences remove the file called com.apple.Terminal (or very similar, on a PC at the moment) in ~/Library/Preferences/ (~ is your home directory in case you are not a Unix user).

    If you want to keep the rest of your Terminal preferences then open that file in the Plist Editor (assuming you have the Developer Tools installed) and remove the offending window frame config from the file.

    If you are doing either of these make sure Terminal is not running as NSUserDefaults caches the preferences to RAM and will probably overwrite your changes!
     
  4. Bakey thread starter macrumors 6502

    Joined:
    Oct 6, 2003
    Location:
    O Donny Boy
    #4
    Thanks for the responses; unforuntately none of the suggestions have worked!
     
  5. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #5
    I'm not sure what you did with the plist file; are you saying that using Finder to go to your home account's Library->Preferences folder, then deleting com.apple.Terminal.plist (or moving it somewhere else) while Terminal is not open doesn't help?

    To be sure about caching, I guess, log out, log in, then delete/move the file without opening Terminal first. Then open Terminal. Same problem?

    When I look at Applications->Utilities->Terminal, it's 601,878 bytes. Yours is the same size?
     
  6. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #6
    Or, before doing that, open Terminal. In the "Terminal" menu, go to "Window Settings...", go to "Window", and make the rows and columns some reasonable number.

    Does that help?
     
  7. Bakey thread starter macrumors 6502

    Joined:
    Oct 6, 2003
    Location:
    O Donny Boy
    #7
    Sorted! Monaco [the default Terminal font] was disabled for some strange reason; renabling has cured the problem!

    I decided to take a look in Font Book as last ditch attempt due to the dialog box in Terminal "Preferences>Display" informing me that the text size was "[Null] 0.0pt"!?!

    Anyway, job done - thank you very much to each and everyone of you for your suggestions and recommendations... ;)
     
  8. jap4n macrumors member

    Joined:
    Aug 10, 2003
    Location:
    wellington, nz
    #8
    i got the same problem!!!!

    thanks! my Monarco was disabled too!! witf!? who dunn that to my fonts...

    :) You saved me from a reinstall!

    (well, i was out of ideas... and am reinstalling a new hdd soon...)
     

Share This Page