Very strange aperture print problem

Discussion in 'Digital Photography' started by mistuk, Dec 21, 2012.

  1. macrumors member

    Dec 15, 2004
    Amesbury, UK
    I've got a really bizarre printing problem with colour using Aperture.

    I'm using 10.8.2 and Aperture 3.4.3

    Printing to an Epson R3000 printer using the latest driver (9.04)

    The problem ONLY occurs when printing directly from Aperture. If I print from Lightroom (trying the test drive demo) it's fine - more bizarrly if I print to PDF from Aperture and then print it's fine.... One more bizarre issue - it's only when I print something using phot black ink - matt black settings don't seem affected.

    The problem is the prints are very dull, reds are dark and skin colour looks terrible (like a deathly shade), but as I say, using Lightroom, or print to pdf first is fine.

    I've checked color profiles, etc, including the ones in the print driver and all look ok. The preview image in the print dialog look fine, as does using soft proofing.

    I've tried:

    reinstalling aperture
    resetting printing system
    reinstalling printer profiles
    reinstalling printer
    repairing colorsync profiles
    repairing disk permissions
    ditching aperture user prefs

    and now I'm stuck!

    Hope someone can give me other ideas to try! :)



    Aperture 3, OS X Mountain Lion (10.8.2), 3.4.3
  2. macrumors 68040

    Designer Dale

    Mar 25, 2009
    Folding space
    How are your ink levels? I printed a jpg out of both Aperture and PhotoShop the othe day and had problems with the saturation on the blues. My printer is an Epson 1400 Stylus Photo. The image in question was just an Internet download of a ship my nephew is serving on so it may have been the image itself. PhotoShops Print Setup kept warning me that it had no color profile. I downloaded the Adobe Print Utility from and got a reasonably OK print.

  3. thread starter macrumors member

    Dec 15, 2004
    Amesbury, UK
    Thanks for the suggestion - ink levels are fine, and, as I say, it prints fine from LR and also going from aperture to print to PDF to print....
  4. macrumors 68020


    Nov 18, 2010
    Make sure you're using the right color profile for both the monitor and printer as to ensure that colors match on screen and on print.
  5. macrumors newbie

    Jul 25, 2012
    Same print problem after updating version 3.4.5

    I was printing perfectly before updating to the new Aperture version. Now my prints are muddy, dark, really terrible. Same print prints perfectly in Photoshop CS6. Noting wrong with printer or ink levels. I think there is a printing bug in the new Aperture.


Share This Page