Video problem with handbrake

Discussion in 'Apple TV and Home Theater' started by liquidsuns, Apr 20, 2010.

  1. macrumors 6502

    Joined:
    Jun 23, 2009
    #1
    A few of my recent handbrake rips (Universal Setting) of two tv show discs and, to a lesser extent, a movie dvd, have had terrible video playback on the Apple tv. Now, on my iMac and iPad they play fine, but on the ATV the videos will, on occasion, get really blocky/pixelated and dark. Almost always during fade in/fade outs (like cutting to commercial break black screens), though sometimes midway through scenes the blockiness will slightly appear. Also, during scenes the brightness level will slightly shift several times getting darker and lighter.

    In the movie dvd and one tv show, it's like the resolution is really low (though it's set at normal). Lines will look slightly pixelated and camera movement causes this to get worse and the video to blur badly. And a few times the framerate got really stuttery.

    Like I said, the blocky/pixelated, brightness changing problem is only happening on the ATV. The seemingly low resolution is noticeable on the iMac too.

    I didn't rip these dvds any differently than any other. Using the "Universal" setting. Any ideas? The dvds rips affected by this issue have been recent rips, but I've done others since and in between that were totally fine.

    The DVDs in question (so far) are; the big bang theory season 2 disc 1 (blocky, brightness problem), always sunny in philly season 1/2 disc 1 (bad resolution) and disc 2 (bad resolution and blocky/brightness) and the new Bad Lieutenant movie (resolution).
     
  2. macrumors regular

    Joined:
    Jan 7, 2009
    Location:
    Colorado
    #2
  3. macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #3
    Sounds like you are missing the weightp=0 option from your advanced x264 string.
     
  4. thread starter macrumors 6502

    Joined:
    Jun 23, 2009
    #4
    Cool. Thanks guys. I'll have to pay attention to that from now on. Seems like if appletv has a problem with a certain setting that the HB preset for appletv would automatically correct if for you. It's also a bit strange (perhaps lucky) that I burned over 50 movies and tv episodes before encountering this problem and then having it happen a couple times in a row.
     
  5. macrumors 68020

    Joined:
    Mar 27, 2003
    #5
    Yes, the pixellation you are experiencing is due to weightp being on by default in hb 0.9.4's copy of x264. In fact the AppleTV is the only current apple device affected by this due to its rather old modified implementation of QuickTime 0.7.1 from the Tiger days. Sucks but its true.

    The built in HandBrake settings should automatically update from now on as of 0.9.4. That said any custom settings you have previously set will not be updated so you will have to manually recreate them.

    weightp=0 added to the option string of affected appletv targeted presets in the Advanced panel will fix this pixelation.
     

Share This Page