Video "spins" like its loading when sending video from iPad/Mac to AppleTV

Discussion in 'Apple TV and Home Theater' started by Hooksta, May 15, 2012.

  1. macrumors member

    #1
    I purchased an AppleTV two days ago and thought I had everything working smoothly...at least until today.

    I have tons of my own movies that I have ripped via Handbrake to my MacBook (MP4 format). I load these movies into iTunes so that I can put them on my iPad for road trips.

    So for the first two days I was amazed how I could access my movie library through "computer" then "movies" on my AppleTV menu. I would select the movie I wanted to watch from those listed on the menu (the movies on my MacBook Pro). The movies would take maybe 10-20 seconds to begin streaming and then would take off with no troubles at all.

    Well today, my movies begin to go to Apple TV but just show that spinning icon on the screen. It may show the first scene but the movie never actually starts. This sits like this indefinitely and I'm not sure what happened to cause this issue. My music is streaming just fine, as are photos, and even other apps like youtube.

    My internet speeds at home tonight show Ping 13, download speed 3.5 mbps, upload 6.5 mbps....so that should be good enough.

    Is there simply something I'm missing or will it always be like this...this being being able to use it a couple of days and then not being able to use it another.

    I also tried sending my movies from the iPad and the same thing happened. So it appears Airplay is hooked up fine.

    My router is a Apple Extreme and I do have a Apple Express upstairs being used as a signal Extender. This is the same setup I used the last couple of days so I'm puzzled.

    Thanks,

    Hook
     
  2. macrumors member

    #2
    I'm always amazed how the questions I have for forums never seem to happen or occur to anyone else. I guess I'm just "special" that way. :(
     
  3. macrumors 68020

    #3
    I have had a similar but not exact thing happen with BD rips but the information you provided is sort of sketchy, so I'll tell you how I solved the spinning wheel for me. When ripping new movies with Handbrake, check "Web Optimize". For movies you have already ripped, use Subler to "Optimize" the file. Both of these move the index from the end to the beginning of the movie and interleaves the audio/video file for easier streaming. Since doing this, I have not had any problems with movies starting to play.
     
  4. macrumors 68000

    iphone1105

    #4
    Reset/Restart your ATV....Your internet speeds and ping have nothoing to do with homesharing. Sometimes it just hangs. Make sure all you OS's are up to date, restart the device(s) and see if ti works.
     
  5. macrumors 6502

    #5
    I think this is more likely a network issue than anything else.
     
  6. macrumors member

    #6
    Out of town at the moment, but will try each of these recommendations. Thanks!
     
  7. Hooksta, May 18, 2012
    Last edited: May 18, 2012

    macrumors member

    #7
    OK...I'm back.

    1. All Apple products are up-to-date and everything was rebooted.
    2. YouTube on ATV loads up videos instantly (impressive even)
    3. Music streaming from MacBook (iTunes) to ATV takes a few seconds but then gets going with very little trouble. Ironically my Denon 1912 receiver (also with Airplay) starts playing music much faster than ATV.
    4. Movies no longer stream like they did on my first two days of ATV ownership. I haven't (knowingly) made any changes that I am aware of. The first two days all my movies streamed just fine from MacBook iTunes to ATV. The worst thing was a small delay...similar to what most of us have experienced waiting for a YouTube video or PPV purchase to begin playing.

    All of my iTunes movies on my MacBook, be them ripped into iTunes from my own DVD collection via Handbrake...no matter if it was the iPod or Apple TV setting....or playing Digital Copy videos. They ALL streamed and played just fine...now they won't at all.

    For whatever reason ATV has decided to no longer do what it did great in the beginning. It sucks!

    For the most part I figured I'd like having ATV, but just about everything requires you to pay additional $$ for it. In addition, I already have DirectTV, HBOGo, an XBOX 360, and my Denon 1912 receiver streams AirPlay audio beautifully. The main reason I wanted this ATV thing is so I could stream movies and not have to hook up my MacBook/iPad to my tv. Without that feature I've yet to see what this thing can do for me that my list above cannot easily replicate.
     
  8. macrumors 601

    #8
    I had the same experience. What had been a flawless :apple:TV3 experience suddenly became what you described. I wonder if it has anything to do with the minor software update from a few days ago?

    I would select a movie to play, a frame of the movie would pop on screen and then the forever wait spinner would spin. If I waited a very long time, I would see minor progress on the buffering bar. If I waited still longer, a bit of the video might start playing but then it would catch up to the (too) slow stream feeding the (pre)buffer.

    At first, I thought it might be just the new movie I encoded, so I went back to stuff I knew had streamed just fine from prior views. Same effect. Then, I went to a small encode from a DVD (knowing this would be both small file size and smallish Mbps). Same effect.

    I've got a wired network that has always worked fine. I checked the AEBS and tested streaming to other devices. All fine. Then, I did the simple thing: unplug the :apple:TV3, wait about 30 seconds, plug it back in. This solved the problem (at least for now). If I was guessing about possible causes, I would guess there might be a bug in the :apple:TV3 software that increasingly eats up the buffer space until there is hardly any left. Then, when you want to stream a film, it's trying to load it into what would be the equivalent of too-little buffer slower than it plays.

    The unplug-wait-plug move probably clears the kludge out of the buffer memory. However, if this is a bug, it will likely repeat from similar use (probably leading to another unplug-wait-plug in the future). Otherwise, it may just be the classic case of needing to occasionally cold start tech to flush all of the memory. Try it and see if that solves your problem too.
     
  9. macrumors member

    #9
    I was really hoping your suggestion would work for me. Darn it though, no luck! Everything is the same...fast youtube, pretty fast music via AirPlay, and hang ups for video streaming. Adding AppleTV to my home product lineup (listed above) is pretty much useless....meaning I haven't seen much of anything it can do that I didn't already have. :(

    Thanks again for the suggestions and the time you took to trying to help me out. I plan to leave this alone the rest of the day, head over to my local airport and complete my A-license check skydive (jump 25!)....I'll be a licensed rookie skydiver. LOL
     
  10. macrumors regular

    #10
    I have the same issue with ATV3, unplugging the ethernet and using the Wifi (i assume its using the 5ghz) solved it 100%. I'm assuming an ethernet driver bug in ATV3.
     
  11. macrumors 601

    #11
    That's interesting. I'm solely using wired and it's been fine. I really thought this apparent bug was related to the buffer but it could be related to the wired connection too. The unplug-wait-plug solution would reset almost everything.

    If it happens again, I'll experiment with unplugging the wired connection and trying wifi (without the reset).

    ----------

    I'm suspecting your source file(s). Open one that's not streaming well in Quicktime, choose (menu) Window: Show Movie Inspector, and share the info next to:
    • Format
    • FPS
    • Data Rate
      [*Current Size

    If some stuff is streaming well but only your own media has an issue, it's unlikely that it's the hardware. I'm betting you have a file(s) encoded beyond what the :apple:TV3 can handle. The info above will probably identify your issue. If you're streaming YouTube video fine, many of the hardware possibilities get eliminated.
     
  12. macrumors member

    #12
    The kicker is the same movies that streamed fine no longer stream fine. This is why I don't think it is movie file issue. Some movies are ripped clicking on the iPod setting and most are selected to the AppleTV setting in Handbrake. I can't play either now (could before) nor can I stream digital copies anymore either. Music still streams fine. YouTube is very quick. It's odd.
     
  13. macrumors 68020

    #13
    Are these blu-rays or regular dvd rips?
     
  14. HobeSoundDarryl, May 18, 2012
    Last edited: May 18, 2012

    macrumors 601

    #14
    I'd blame the hardware except you say that it's playing youtube video just fine. :apple:TV can't discriminate one video file vs. another ("I'll play these youtube videos great but play his own video files poorly").

    But, the new bit of info you offered- that these are videos that used to play just fine- implies something else. If it was me, I'd now focus my attention between the computer on which iTunes runs (and thus your store of these video files) and your router. In other words, the YouTube video stream playing fine implies all is well between router and :apple:TV. So focus the investigation on what's left.

    I now suspect the problem is between your computer and your router. Try things like directly connecting your computer to your router with an ethernet cable. Then try wifi close to your router. If you have a different computer in your house, take one of your videos that won't play and copy it to that computer, run iTunes on that other computer and see if it will stream smoothly to your :apple:TV. If you have an iDevice, sync one of the problematic videos to that iDevice and then try airplaying it to your :apple:TV.

    These experiments will reduce the possibilities down. For example, if that last one works, the whole idea that it might be the file encoding is pretty much put to bed. If another computer works, it strongly implies your existing computer has some issue. Etc.
     
  15. macrumors 68020

    #15
    I had the same experience with files not consistently playing. First time I queued Tree of Life up started up fine. Next time it would do exactly as you describe, start and just spin and spin and spin. It only happens with blu-rays however (larger files).

    I will make one last pitch to for optimization of the files, either with Subler or Handbrake (you won't have to do a lengthy re-encode with Subler). I have not encountered this problem again since making "Web Optimization' part of my transcoding default settings. What this does is relocate the moov atom from the end of the file to the beginning and interleaves the audio/video streams. This improves the ability to stream the file and provides the necessary indexes to the aTV at the start of the file. It's not a big deal to try it and see if it works. It takes like 5 minutes to optimize with Subler.

    Good luck. I'll leave you alone now.
     
  16. macrumors newbie

    #16
    Same issue with Blu Ray rips

    Hello,

    I just purchased the ATV 3 yesterday and begain trying to rip my blu-ray MP4encodes that I did with Handbrake. When streaming to ATV, the wheel just spins constantly..it will eventually start but it takes almost 10 minutes (then seems to play fine). Very annoying.

    The MP4 files are huge (8-10gigs)..as I am using the Apple TV settings in Hanbrake and "Large file Size" to not lose the quality as much as possible. Other than that, I am not changing any other settings when I encode.

    I ripped a regular DVD (not Blu-Ray) and that seems to start in ATV fairly quickly. No other issues playing music or viewing youtube stuff. It's got to be the large file sizes that is causing the issue here.

    I am going to try and "web optimize" feature in Hanbrake to see if that helps.

    Really trying to get away from handling Blu-Ray discs..this was the whole reason I purchased ATV in the first place.
     
  17. macrumors 68020

    #17
    Please post back and let us know if that helped with your problem. I have many BR rips to mp4 and they all start very quickly (maybe a minute at most) using wifi. But....I optimize all of my files.
     
  18. macrumors 603

    #18
    Yup, optimizing is the key, particularly over Wi-Fi.

    Here's my tutorial: http://forums.macrumors.com/showthread.php?t=1496052
     
  19. macrumors newbie

    #19
    Hi,
    Thanks for the reply. I just re-encoded a BD movie with Handbrake and clicked on the "Web Optimize" button (with MP4 for Apple TV 3). It is still taking forever to load (buffer)..the wheel just spins for about 10 min as before.

    I don't have a MAC, I am using windows so I am not sure if I need to optimize it again with a 3rd party software. I have a very good wireless connection and also updated my ATV 3 with the latest updates.

    Any other suggestions?
     
  20. macrumors 68020

    #20
    By chance, is your wireless "g" or "n"?
     
  21. macrumors newbie

    #21
    The wireless router I have says 54Mbps..so I am guessing it's a g

    I am googling to figure out how to confirm what I have..

    thanks!
     
  22. macrumors 68020

    #22
    If it is "g", I suspect you will have a problem. It's not just about speed of data transmission but also, bandwidth (think of it as diameter of the pipe). My wife and I had problems using g. When she was on the iPad and I was streaming music we would get serious cutouts. Switched to n and have not had a problem since. Our speed on both was similar to yours.
     
  23. macrumors newbie

    #23
    Thanks- is it simply a matter of going out and purchasing a wireless n router in place of my g? I might do that today to see if it works
     
  24. macrumors 68020

    #24
    First of all, make sure your route is in fact using "g". If that is the case, go to a place with a good return policy. Try it and see if it solves the problem. If not, return it...unless you just want a new router for some reason. I use the Apple Airport Extreme Base Station. Ease of setup (basically just plug everything in) and the fact that it incorporates seamlessly into the Apple environment made it worth a few extra bucks.
     
  25. macrumors newbie

    #25
    Great news! The new modem worked..I can now stream the large files relatively quick. I purchased a netgear N600 dual band router ($79.99 at Best buy) which is much better than the old antiquated one I had been previously running.

    Thanks so much for all those that helped!

    If anyone is having issues with the spin- make sure you have an fast router!
     

Share This Page