Videos from Digital Camera in iMovie...

Discussion in 'Mac Basics and Help' started by Blazer5913, Feb 27, 2007.

  1. Blazer5913 macrumors 6502

    Jan 20, 2004
    Just a quick question... I have a digital camera ( Sony DSC W70 ) and I took a bunch of videos on it over our vacation. When we got back I imported all the pictures and video in iPhoto, and the pictures look great as well as the videos work fine (picture and sound). Yet, when I import them into iMovie, I can get the video but no sound. Same thing in FCP Pro, just no sound. Any suggestions? Thanks guys
  2. surfer99 macrumors 6502

    Jul 30, 2006
    I had the exact same problem. It had to do with the format the videos are in. I was able to fix this with a program called visual hub which offers a free trial version (simple google search will pull it up). All it does is change the format of any video to any type of format you want. I had to play around and try different formats before I got one that was able to bring the sound and video over. My videos were short 30 sec clips which you can change the format for with the free demo but I think if you want longer clips reformatted you have to buy the software. Hope this helps
  3. tilman macrumors regular

    Feb 28, 2006
    I load such clips into MPEG Streamclip (free), export them back to DV, and then import the DV into iMovie. Quicktime (which is at the core of many Apple video features) cannot de-mux the audio data from certain MPEG formats.
  4. Blazer5913 thread starter macrumors 6502

    Jan 20, 2004
    Wow, thats really a pain. Anyways, I have both of those programs so I'll give them a try...

Share This Page