Virtual PC XP install broken; how do I acces files?

Discussion in 'Mac Apps and Mac App Store' started by Sporty G, Apr 5, 2006.

  1. Sporty G macrumors member

    Joined:
    Jan 27, 2005
    #1
    Hello everybody, last fall I bought my parents a Mac mini for their basic computer needs. However, I discovered that they use several Windows-specific applications that have absaloutely no Mac counterparts. Thus, I begrudgingly purchased and installled Virtual PC 7 w/ XP Pro using my student discount.

    A couple of days ago my Mom called complaining that Windows was "broken." She appears to be correct, Virtual PC itself loads without a problem but the actual Windows session that is currently installed won't even boot far enough to ask for the Admin password. I'm content with simply wiping away this session and starting fresh, but I need to back up 2-3 database files for her Dog Pedigree programs first.... I just can't figure out a way on earth to do this. If it was a dedicated PC, I'd simply plug the HD into another system and drag the files across but I am just stumped... does anybody know how I can access the HD, or more specically the "My Documents" folder, on the Windows XP Pro session from OS X??? I, stupidly, never activated the Shared Folders option.

    Thanks in advance~!
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Do not wipe your VPC virtual Windows hard drive disk image file. Move it out of the way and reinstall VPC. Once you have done that try to add your defective disk image as a second virtual hard drive. If it works, then you can retrieve your files.
     
  3. Give me money macrumors newbie

    Joined:
    Apr 4, 2006
    Location:
    Canberra
  4. Sporty G thread starter macrumors member

    Joined:
    Jan 27, 2005
    #4
    Thanks for the post sir! But it didn't correct the problem.... :(
     
  5. Sporty G thread starter macrumors member

    Joined:
    Jan 27, 2005
    #5
    Well, I managed to extract the files that my Moms needed... I booted the Virtual PC and then loaded up the image.... I hit F8 and loaded Windows XP in Safe Mode with Command Prompt. I exited the Command Prompt, hit CTRL-ALT-Delete and then launched Explorer.exe from the Task Manager... FORTUNATELY Windows recognized a USB drive I plugged in after many, many, many failed attempts! So there we go, data backed up! :)
     

Share This Page