Virus warning and page redirect in safari - touch 3g

Discussion in 'iPod touch' started by Jig101, Sep 30, 2010.

  1. macrumors newbie

    Joined:
    Sep 30, 2010
    #1
    I keep getting this pop up warning and page redirect when ever I am in the middle of using the internet with safari. "Warning!
    On your computer detected the malicious code.
    Should immediately make sure that your system is safe! Killing Hazard
    ® for Microsoft Windows XP immediately started to work"
    When I try to close it, it starts to scan. What can I do to fix this?

    My 3rd gen touch has updated driver and popup
    Blocker is on. Thanks!
     
  2. Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Missouri
  3. thread starter macrumors newbie

    Joined:
    Sep 30, 2010
    #3
    That's the thing. It is not site exclusive. It happens when I open safari and type in an address. It happened while I was pulling up this forum. It hAppens when I pull up hotmail or google or other sites... It's like the iPod is infected with something. Is that possible?
     
  4. Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Missouri
    #4
    No. Do you have any other tabs open?
     
  5. thread starter macrumors newbie

    Joined:
    Sep 30, 2010
    #5
    No. Not usually. What happens is the virus warning pops up and then opens a new page with the download advert

    Here is a snap shot of the pop up
     

    Attached Files:

  6. macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #6
    That's delicious ;)! It's a Kind of Javascript-Redirector Fake-Antivirus. Just turn off JS and you should be fine. Eventually will need to reboot or close down safari.
     
  7. thread starter macrumors newbie

    Joined:
    Sep 30, 2010
    #7
    Thanks. I'll give it a try...
     
  8. macrumors regular

    Joined:
    Apr 18, 2010
    #8
    Does it happen in other apps that let you browse the web?

    It might be your network- does any other laptop/computer connected to the same wireless network have the same problem?
     
  9. macrumors 68000

    mKTank

    Joined:
    Jul 2, 2010
    #9
    It's your network, hence the IP in the address bar. It infected your router, and it forcing random redirects.
     
  10. macrumors 65816

    tablo13

    Joined:
    Jul 29, 2010
    Location:
    Edmonton, Alberta, Canada
    #10
    Does it do that in Safari too? Looks like the screenshot is in Facebook
     
  11. thread starter macrumors newbie

    Joined:
    Sep 30, 2010
    #11
    It happens when I am using safari to load pages but not a direct app.


    That wad facebook opened via safari not the app. It happens when I open any site, but not every time.


    Yes it does happen with other computers as well on my network. Router, huh?


    How do I fix that?
     
  12. macrumors regular

    Joined:
    Mar 23, 2010
    #12
    Yep, it's the router.

    Try resetting it.
     
  13. macrumors regular

    supermassive

    Joined:
    Sep 15, 2010
    #13
    If your router is infected you might need to reinstall the firmware.

    But try resetting it first. Disconnect the power-plug for a couple of minutes (1-2). If this doesn't help, you could try a factory-defaults-reset, all settings will be gone! You'll need to reconfigure at least your ISP-Login-Data.
     

Share This Page