Visual editor in eclipse 3.3

Discussion in 'Mac Programming' started by X1Lightning, Jul 5, 2007.

  1. macrumors 6502

    X1Lightning

    Joined:
    Feb 19, 2007
    #1
    i downloaded the latest version of eclipse for the mac, version 3.3
    i normally use eclipse in windows, but I'm trying to break away from windows as much as i can.
    anyways....
    i cant seem to find a way to open the visual editor. its like its not there, and it seems odd they would leave that out of the mac version of eclipse...
    anyone know what I'm missing?

    Thanks
     
  2. macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #2
    I haven't installed 3.3, but VE wasn't part of the standard Eclipse install in previous versions, for any OS. It's a separate project. Take a look at the update option.

    Edit: I'm downloading 3.3 for Linux now. I'll get back to this later.

    Edit 2: A note in the FAQ says OS X is not supported. But I'm pretty sure I used it in 3.2 on my Mac - presumably that means the dev team won't respond to questions about or bugs found on a Mac.

    Edit 3: VE isn't present in 3.3 (Europa) for Linux either, and there doesn't seem to be a way of downloading it from the built in update sites. I suggest you download it using the instructions in the FAQ I linked to above.
     
  3. thread starter macrumors 6502

    X1Lightning

    Joined:
    Feb 19, 2007
    #3
    i don't remember installing the VE in 3.2, but maybe i did, a few days ago i tried copying the plug in from the plug in dir and features dir on my win box to my mac, but that didn't work.

    I'll give this a shot and let you know if that worked for me
     
  4. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    As it turns out, VE on Mac OS X is supported in the 1.3 release, which is available from the VE project page on eclipse.org. The FAQ hasn't been updated since 2004 (!) although the latest release was in late June 2007.
     
  5. macrumors newbie

    Joined:
    Jun 11, 2007
    #5
    I'm also trying to run Eclipse with Visual Editor under OSX... but I can't find the 1.3 release anywhere on the VE page. Also, when I attempt to install VE through software update, I'm told I'm missing the org.eclipse.pde dependancy...
     
  6. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    That's because the 1.3 release doesn't exist yet. I meant 1.2.3jem, which is the current release, found here: http://download.eclipse.org/tools/ve/downloads/drops/R-1.2.3_jem-200701301117/index.html
    PDE is part of the main Eclipse package. I'd recommend downloading Eclipse 3.3 (Europa) if you don't already have it, found here: http://download.eclipse.org/eclipse/downloads/drops/R-3.3-200706251500/index.php
     
  7. macrumors newbie

    Joined:
    Apr 10, 2007
    #7
    How is VE working in eclipse 3.3 for OS X? I tried using it in 3.2, but could never get it to work; opening a class with VE would just hang every time (apparently a known bug for OS X...). I ended up resorting to using NetBeans & Swing... hoping things have changed in this release.
     
  8. ceu
    macrumors newbie

    Joined:
    Aug 11, 2007
    #8
    I have the same problem

    This is really a bummer and very annoying.
    Anyone else have any luck?
     

Share This Page