VLC Dock icon keeps disappearing...

Discussion in 'Mac Apps and Mac App Store' started by Bakey, Jan 6, 2006.

  1. Bakey macrumors 6502

    Oct 6, 2003
    O Donny Boy

    This has happened to me several times now and I'm somewhat confused as to why!

    Pretty much as the subject heading goes, the VLC icon in my dock frequently disappears and is replaced with a "?".

    It only seems to happen on a restart, to which most of you will say "well, don't restart it then!?!" - but I often run Onyx [maybe a couple of times a month] and as a result need to restart the machine once completed...

    Could anyone shine any light onto the matter as to why I'm suffering this? ;)
  2. solaris macrumors 6502a


    Apr 19, 2004
    Oslo, Norway
    Dont run OnyX! :p

    Seriously, I really think its caused by OnyX deleting some cached files.
    I have never used OnyX and my VLC icon have never disappeared.
  3. ahuman7341 macrumors regular

    Apr 18, 2005
    Fairbanks, AK
    it could be that your dock preference is corrupted, go /Users/'your user name'/Library/Preferences and delete the file com.apple.dock.plist. this will delete all the info about whats stored in your dock so you will have to put everything back in, but now things wont go away.
  4. neocell macrumors 65816


    May 23, 2005
    Great White North
    Or instead of clearing the whole dock, just drag the VLC icon off and then re-add it and if it still disappears do the dock preferences erase and then rebuild the whole thing
  5. kretzy macrumors 604


    Sep 11, 2004
    Canberra, Australia
    I've had the same problem, no matter how many times I drag it to the dock, after I quit from VLC it disappears. :confused: Got rid of onyx and it seems to be fine now.
  6. Bakey thread starter macrumors 6502

    Oct 6, 2003
    O Donny Boy
    Thanks folks!

    So confused was I [slightly Yoda-ish I know!!] that after re-reading my post and the first response of not using Onyx it all became crystal clear...

    Adding the VLC icon back to the dock and several restarts later it's still right there where I'd left it - no more '?'.

    From this point forward I shall use Onyx much more sparingly... ;)

    Thanks once again...

Share This Page