VLC - how do I change the language?

Discussion in 'Mac Basics and Help' started by Kimi, May 13, 2006.

  1. Kimi macrumors regular

    Joined:
    Oct 29, 2005
    Location:
    Newcastle, England/ Stirling Scotland
    #1
    I've been using VLC for ages, but for some reason when I opened it today it was in Russian. I would be fine with that, but my Russian isn't great (but I do now quite a bit). What I want to do is change it back to English. Can anyone give me directions on how to do this?

    I've already tried to re-install it (including prefereces), but that didn't help.
     
  2. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #2
    1st try opening the video up in MPlayer or another video player to be sure the subtitles aren't embedded in the video. If they aren't then open up VLC's preferences and click reset all at the bottom, I'm not sure, but I'd guess that would probably get you back to english, but it'll lose any other pref changes you've made as well.
     
  3. Kimi thread starter macrumors regular

    Joined:
    Oct 29, 2005
    Location:
    Newcastle, England/ Stirling Scotland
    #3
    No, the program is in Russian (all menus); not the videos, they work fine.

    Anyways, now it's in French...

    I've got it, back in English. For some it's useing the second language on the list in the system preferences (I've put another English there now). I wonder why it's doing that...

    EDIT: only some of it is back in English. It's a French/English hybrid. I can read French very well, so I'm ok with that.
     
  4. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #4
    Weird. If you ever figure out the problem be sure to post an update so the answer gets in the MR database.
     
  5. eish2306 macrumors regular

    eish2306

    Joined:
    Apr 30, 2013
    Location:
    Wales
  6. aalu91 macrumors member

    Joined:
    Aug 9, 2010
    #6

    Same here!!! Can't be a coincidence something is up with VLC
     
  7. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #7
    This zombie thread has been resurrected after 9 years! Wild.
     
  8. DeltaMac macrumors 603

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Even though the thread is ancient in computer years - appears that something happened nearly identical to that long ago.
    I saw the same today, menus also in Basque language (took me a while to figure out what language it was).
    I have no life experience with Basque, so had to play around in Preferences a little, until I recognized interface settings, with a dropdown for lots of languages.
    I could see it was set for Auto, and the next item appeared to be something like English. Switched to that, and then Quit VLC. Opened again to correct menu language.

    Probably just some weirdness in the latest ElCap beta, as I was just using VLC a few days ago, with the same video file, and the only change has been the new beta.
    I expect that VLC will get some kind of patch very soon, unless the issue is simply a beta bug (that needs to be reported, eh?)
     
  9. pedro_martins macrumors member

    pedro_martins

    Joined:
    Aug 4, 2015
    Location:
    Portugal
    #9
    If you guys are all using El Capitan, i think that it is a known issue.
     
  10. Dudikowski macrumors newbie

    Dudikowski

    Joined:
    Jul 28, 2012
    #10
    I saw the same thing with El Capitan. I right clicked VLC and show content and removed all but english and my local language. First I removed all unnecessary .proj folders in /Contents/Resources but it didn't work. Then I found another folder here /Contents/MacOS/share/locale. After cleaning up that folder VLC started with English again.
     
  11. Kroo macrumors regular

    Kroo

    Joined:
    Jul 17, 2015
    #11
    Thanks. That did the job.
     
  12. Day release macrumors newbie

    Day release

    Joined:
    Aug 11, 2015
    #12
    Lifesaver! I am on El Capitan also. Your fix worked a treat, thanks mate.
     
  13. zeusje macrumors newbie

    Joined:
    Aug 13, 2015
    #13
    Thanks bud! That worked.
     

Share This Page