VLC stretch video?

Discussion in 'Mac Apps and Mac App Store' started by motulist, May 14, 2005.

  1. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #1
    Sometimes when I download a video, the video file will be in 4:3 but it is a letterbox of the actual video content which is at 16:9. Then when I fullscreen it on my widescreen powerbook I get bars on the top AND bars on the side. Is there a way to make vlc fullscreen according to the width and ignoring the height which it will just crop off the screen?


    video file
    ___________________
    |000000000000000000|
    |------------------------|
    |XXXXXXXXXXXXXXXX|
    |XXXXXXXXXXXXXXXX|
    |XXXXXXXXXXXXXXXX|
    |------------------------|
    |000000000000000000|
    --------------------------



    video file on my wide screen
    ____________________________
    |0000|000000000000000000|0000|
    |0000|------------------------|0000|
    |0000|XXXXXXXXXXXXXXXX|0000|
    |0000|XXXXXXXXXXXXXXXX|0000|
    |0000|XXXXXXXXXXXXXXXX|0000|
    |0000|------------------------|0000|
    |0000|000000000000000000|0000|
    --------------------------------------


    Thanks
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I think I may have found the setting(s) you need. Here's a screenshot:

    link to screenshot
     
  3. motulist thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #3
    Wow! You found it! That did exactly what I wanted. Thanks wrldwzrd89!
     
  4. penx macrumors newbie

    Joined:
    May 23, 2005
    #4
    I have the same problem but none of the options on the screenshot above help, 'stretch aspect ratio' stretches the video horizontally. It does not retain the aspect ratio of the video whilst using the full width of the screen, which is what I thought the original poster was asking...

    Anyone have any ideas, or am I missing something?
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    Depending on the dimensions of the video and your screen, that may not be possible. The original poster wanted to get rid of the black bars to the left and right of full-screen movies in VLC. Doing that REQUIRES changing the aspect ratio.
     
  6. penx macrumors newbie

    Joined:
    May 23, 2005
    #6
    I have a 16:9 video that has been captured and saved as 4:3, with the excess space just being black with the capturer's logo. I now want to play this on a 16:9 screen (my new Apple display :)) and have the black bars that are part of the capture cropped off (a zoom function would be nice...) but instead vlc plays the video with a black border all the way round.

    From the first post in this thread it looks like they were trying to do the same thing but I can't figure out a way to do this with VLC, the crop function just acts really weird and I can't find a full-screen zoom option (similar to that found in Apple's DVD player).

    Thanks for your help btw... Plus on a side note, has anyoune found VLC 0.8.1 to be extremely buggy in Tiger? I have tried trashing my prefs several times :(
     
  7. motulist thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #7
    Well, at first glance I thought wrldwzrd89 had given me the solution (if you look at wrldwzrd89 's post there's a link to a screen shot showing the option you need to check). HOWEVER, it turns out that it isn't the real solution after all. You see, at least for the powerbook display, the screen is wide, but it is not actually 16:9. So when the video is stretched out to fill the screen, the aspect ratio gets smushed down.

    Anybody else have any new ideas?
     
  8. motulist thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #8
    Let me restate the question. Does anybody know how to make vlc zoom a video to the full WIDTH of the screen while maintaining the aspect ratio? Meaning it will zoom in with the correct aspect ratio and crop of the top and bottom until it starts to crop off the actual top and bottom of the movie frame?
     
  9. Lacero macrumors 604

    Lacero

    Joined:
    Jan 20, 2005
    #9
    It depends on how the video was encoded. However, you can override the aspect ratio of the movie file by going into VLC preferences, click on Advanced, and highlight the Video preference pane.

    Scroll down to the very bottom and type in 1 for the "source aspect ratio".
     
  10. motulist thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #10

    The aspect ratio is correct for the movie. The problem is it was encoded from a source that has a 16:9 movie encoded for a 4:3 screen. So when you view it on a wide screen you get the normal letterbox horizontal black bars on top and bottom but also now have black bars on the sides. So the movie is approximately the shape of the screen, but it has black borders on all 4 sides. I've seen zoom options in the prefs but they don't seem to do anything.

    The only solution I've found is very inelegant. I use the universal access zoom feature in OS X to zoom the whole screen in, but it's a real quick 'n dirty hack and has problems of it's own.
     
  11. Theome macrumors newbie

    Joined:
    May 24, 2005
    #11
    hi,

    i had the same problem, and this settings solved it for me (see attachment)

    have a look at the documentation:

    (http://www.videolan.org/doc/play-howto/en/ch04.html)

    edit: i forgot one thing: in preferences -> video, choose the Video filter module "Crop video filter"
     

    Attached Files:

    • vlc.png
      vlc.png
      File size:
      62.1 KB
      Views:
      1,079
  12. penx macrumors newbie

    Joined:
    May 23, 2005
    #12
    Thanks! Exactly what I needed, I was trying to do that before but couldn't find the crop feature documented anywhere.
     

Share This Page