Voicemail external speaker problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mtroofer, Jan 25, 2012.

  1. macrumors newbie

    Joined:
    Jan 25, 2012
    #1
    Hello, new to the Iphone 4s. Jailbroke with absinthe, downloaded a few apps. Bitesms, activator,winterboard and hands free siri.

    My problem started yesterday, when playing back voicemails on visual voicemail it automatically plays the message through the external speaker. Pushing the speaker button changes the button but not the sound. Annoying.

    Please help
     
  2. macrumors newbie

    Joined:
    Jan 26, 2012
    #2
    Hey Mtroofer,

    Sorry, I don't have any answers for you. I just wanted to add that I am having the SAME problem with my recently Jailbroken iPhone 4S with Absinthe 0.2 for Windows on my iPhone running 5.0.1 (9A405).
    I posted in the Modmyi forum as well, but wanted to keep track of this thread to see if anyone had any suggestions.

    In addition to the voicemail playback issue, I'm having two other issues as well:

    1.) When I type on the keyboard, I don't hear any clicking sound. ("Keyboard Clicks" in settings is set to On)



    2.) When I receive a new email, I don't get a sound. The phone vibrates, but no sound letting me know I have a new email. I do get these notification sounds for a new text or voice mail, just not one for new emails.


    And of course the Voicemail issue. Here's what mine is doing -

    When I play back voice mail messages, the sound only plays through my bottom speaker. I can't get it to play through the normal front mic (same one you listen to when on the phone). So I actually have to put the bottom of my phone up to my ear when playing back voice mails so I can hear them. The Speaker button on my voice mail screen doesn't change anything if I try to press it so it appears to be stuck.


    All other sounds work fine (sounds during games, sounds during phone calls, speaker phone during phone calls, ipod, Siri sounds, etc...). My mute button is not switched on and I've made sure the settings appear correct for these sounds to play so I'm not sure what it could be.


    Anyone have any idea what me and Mtrooper can do to correct the sound issues?


    Thanks!!!
     
  3. thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #3
    Excatly what mine is doing, but you put it in a much clearer form. This is annoying as heck and I have tried everything. Hopefully somebody knows a way to fix it.
     
  4. macrumors newbie

    Joined:
    Jan 6, 2012
    #4
    i think your problem voicemail in ecternal specker and if you change your equipment to pperhapss your problem is solved because your company you define i think best rank in word
     
  5. thread starter macrumors newbie

    Joined:
    Jan 25, 2012
  6. macrumors newbie

    Joined:
    Jan 26, 2012
    #6
    Open Cydia and update Hands-Free. They fixed a bunch of bugs.

    This update seems to have fixed two of my three issues (#1 and #2 mentioned above), but unfortunately I'm still having the voice mail issue (#3 above). Sound is still coming from the bottom speaker.


    Anyone having any ideas what we can do to get the voice mail playback working correctly?
     
  7. macrumors newbie

    Joined:
    Feb 3, 2012
    #7
    Found a temporary fix.

    Lock your phone. Double click on the home button. At the top right you will notice that it gives the option of iPhone speaker or iPhone. Click iPhone. This will work immediately and you can listen to visual voicemails privately. You will have to repeat because it will default to iPhone speaker again. Hope someone can fix this bug.
     
  8. macrumors newbie

    Joined:
    Jan 26, 2012
    #8
    Thanks for the temp fix.

    Has anyone else run into this? Does anyone else have any ideas for a real fix?

    Thanks!
     

Share This Page