Voicemail issue with iOS 5.1

Discussion in 'iOS 5 and earlier' started by LWP777, Mar 15, 2012.

  1. macrumors member

    Joined:
    Sep 20, 2010
    #1
    Ever since I updated to iOS 5.1 I've had some new voicemails that I was unable to play without rebooting my iPhone 4S. I will see the new voicemail in my visual voicemail but it will show 0:00 and not let me play the message. When I reboot, it will notify me of a new voicemail and I'm able to listen. This has happened 4-5 times. It also happened today on my wife's 4S so it's not just exclusive to my phone. I am on the Sprint network.

    I tried searching the forums but didn't find any posts with a similar issue.

    Any ideas of how to resolve this? Thank you!
     
  2. macrumors newbie

    Joined:
    Mar 18, 2012
    Location:
    Chicago, IL USA
    #2
    Voicemail Issue

    Were you ever able to resolve this? I am having the same issue is iOS 5.1 on the 4S, on Sprint. Mine is so bad that I have to reboot my phone EVERY time i receive a voicemail.
     
  3. thread starter macrumors member

    Joined:
    Sep 20, 2010
    #3
    No, I have not resolved this. I'm shocked that nobody has really responded to this post! I also am having to reboot my phone each time.

    When you upgraded to 5.1, was it interrupted at all? I think I went from wifi to 3G. I wonder if that had something to do with it.
     
  4. macrumors 68000

    pdqgp

    Joined:
    Mar 23, 2010
    #4
    AT&T works fine here. Sprint thing?
     
  5. macrumors newbie

    Joined:
    Mar 20, 2012
    #5
    I am having the same issue is iOS 5.1 on the 4S, on Sprint. Mine is so bad that I have to reboot my phone EVERY time
     
  6. macrumors regular

    Joined:
    Jul 5, 2011
    #6
    FWIW I'm on o2 (UK) and have been able to listen to voicemails without any issue. Hope your issue gets fixed!
     
  7. macrumors newbie

    Joined:
    Mar 18, 2012
    Location:
    Chicago, IL USA
    #7
    I have not been able to resolve this as of yet. I can't seem to find any solution online either, haven't called Apple yet because I know their first suggestion is going to be to erase my phone and start over...
     
  8. macrumors member

    Joined:
    Mar 10, 2012
    Location:
    New Jersey
    #8
  9. macrumors demi-god

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B176 Safari/7534.48.3)

    With Vz and my iPhone4, no problems.
     
  10. macrumors newbie

    Joined:
    Mar 28, 2012
    #10
    Same

    My wife and I both have iPhone 4s with Sprint. iOS 5.1 update has done same thing to our voicemail. I have to reboot phone nearly every time. I have a 32 GB phone. I have not tried the back up and restore. Is this confirmed as a solution?
     
  11. macrumors newbie

    Joined:
    Apr 5, 2012
    #11
    Iphone voicemail issue

    My wife and I both have Iphone 4S's on sprint and are experiencing the exact same problem. Ever since we upgraded to IOS 5.1, when voicemails come in, they are displayed but with 0:00 as if the person didn't leave a message. We never had this problem on 5.0, but we've asked a Genius Bar tech and he had no knowledge of the problem.

    Any hints on how to fix it or get it fixed?

    Iphone 4S 32gb
     
  12. macrumors 68020

    bluedoggiant

    Joined:
    Jul 13, 2007
    Location:
    MD & ATL,GA
    #12
    not on AT&T 64gb iphone 4s
     
  13. macrumors member

    Joined:
    Oct 11, 2011
    #13
    Has anyone in this thread (or anyone else experiencing this issue) been able to resolve this voice-mail problem?

    I contacted Sprint (and this only affects Sprint iPhones AFAIK) and they are aware of the problem and said they were currently working w/ Apple to resolve it but that was over a month ago. The rep told me they thought the latest iOS release was going to resolve the problem but it does not. Sprint can "reset" your voice mail temporarily fixing the problem but the problem resurfaces for me within days (sometimes hours).

    So far the only thing that works for me is deleting the voice mail and then going into deleted messages and undeleting it. I can then listen to the message. I really hope this is resolved soon or this could affect my next iPhone purchase. I gotta get my voice mails! :mad:
     
  14. macrumors newbie

    Joined:
    Jul 11, 2012
    #14
    1. Exit out of the phone app and go to the home screen
    2. Tap twice on the home button to bring up currently running apps
    3. End the Phone App process by continuing to hold that icon until a minus sign appears. Tap the phone icon again to end it.
    4. Tap the home button again to return the device to the regular home screen
    5. Re-launch the phone app
    6. Wait a few seconds. This will prompt the device to re-connect to the Voicemail server and download all messages. The messages will all be playable.
     
  15. mds
    macrumors 6502

    Joined:
    Oct 6, 2006
    #15
    I've had this problem as well and following the steps above solves the problem. My guess is it will reappear, but it isn't too difficult just to kill the phone app once in awhile. Thanks!
     
  16. macrumors 6502a

    Macman756

    Joined:
    Sep 24, 2008
    Location:
    Atlanta, GA
    #16
    It just hasn't downloaded yet. Carrier issue. Reset your network settings
     
  17. macrumors newbie

    Joined:
    Aug 20, 2012
    #17
    Funny how I'm reading your complaint about this "known issue" you posted in March 2012 and It's August and this is still an issue. I can't get a voicemail from Sprint unless I turn the phone off then back on. I wonder how many more months will go by before they fix it.
     
  18. thread starter macrumors member

    Joined:
    Sep 20, 2010
    #18
    Yeah, it's ridiculous. Have you updated to iOS 6 yet? I haven't had the problem since I updated. (knock on wood)
     

Share This Page