VoIP network settings help

Discussion in 'General Mac Discussion' started by mrgreen4242, Mar 10, 2005.

  1. mrgreen4242 macrumors 601


    Feb 10, 2004
    I just received my equipment from Broadvoice for VoIP today. The hardware, from them, is a Sipura SPA-2100. This device plugs into your cable/dsl modem, then you computer or router and telephone plug into it.

    The Sipura device seems to be working fine. I can plug my cable modem into it, then plug in my phone and my iMac directly to it and everything is just fine. (I can get online with my computer and makes phone calls from the VoIP line). The trouble comes in when I connect my router to the Sipura box.

    The router seems to be failing to get an IP from the Sipura device. It's a Belkin F5D6231-4 wireless router. It definitely seems to be seeing the Sipura VoIP device, as it will get the DNS address for my ISP from it, but it won't pull down an IP address.

    I've tried every imaginable setting. I have made the LAN addresses the same and different, I have tried NAT filtering on and off, I have tried manually setting the IP address on the Belkin to an address in the DHCP pool of the Sipura. I have tried using the sipura LAN hostname or the hostname off. I have used the router MAC address, and I have cloned my iMacs MAC address.

    I can't find anything on either the Belkin or Broadvoice websites, and the Broadvoice tech support guy wasn't much help (he seemed to know what he was talking about, but just didn't have much useful information to share).

    Anyone else use either Broadvoice VoIP service or a Belkin router with any VoIP provider? What kind of settings did you have to use?

    Thanks for ANY help!!!

  2. BillHarrison macrumors 6502

    Jul 25, 2003
    Well, here are a few comments on the subject. I tried broadvoice, and found it less than reliable. However, that does not appear to be the problem here.

    Is there a reason you are attempting to use the voip box as the router? I was very leary of that, and instead ran the voip box off my router. Worked perfectly. There was some discussion in the manual of possible degraded signal quality, due to bandwidth contention, however, I have a fairly fast (5mbps Cable) connection, so I was not concerned. Everything has been perfect to date. As to your exact problem, I cannot be sure, but when you say your router is using your "Dsl" settings, it should not have too, as the voip box is doing this for you, and then acting as a router. So the router your plugging into it should be set just to recieve an IP dynamically, using for example the "cable" settings. If you still have it setup for PPPOE, that could be your problem, as your router no longer NEEDS to get the PPPOE, it is now on the internal network controlled by the voip box, that will do the PPPOE signon.

    If this is not clear, please inquire further, as I fully understand networking, but its sometimes difficult to express what i see. :)
  3. mrgreen4242 thread starter macrumors 601


    Feb 10, 2004
    Well, I mentioned DNS settings, but don't think I said anything about DSL (other than that the VoIP router could connect to cable or DSL modems).

    Anyways, I have it working now... I'm actually a network and telecom tech myself, so when I couldn't get this working, I was a bit baffled.

    The reason for putting the VoIP router in front of my router is twofold. First, as you mention, it has better packet prioritization than a regular home router does. By giving priority to the VoIP packets I can assure high quality of telephone service, which is very important to the WAF (wife acceptance factor). I have enough bandwidth to easily support dozens of incoming calls, but the trouble comes form Comcast's aweful upload speeds.

    I max out around 350kbps down and a whopping 30kps up. So, at best I can make a threeway call, and have enough upstream left to request a web page. Worst case is that my wife is talking to her Mom or something important and I am playing WoW and walk into IF (a really busy area of the game) and the resulting spike in bandwidth usage (on the upstream) causes her to have her call broken up.

    The other reason is simple geography. The cable modem and phone are on one side of the room, and the router is on the other, with all the computers. I have craftily run a single CAT5 cable across this space, so everything is good now. If I were to put the VoIP device behind the router I would have to either move the router and run lots of cable or buy wireless cards for everything, or move the phone, which damages the WAF again.

    But, it is all moot, as I figured it out. What I ended up doing is disabling my Belkins DHCP service, and then plugged the VoIP router into a 'normal' port on it so that the Belkin is acting like a switch and the VoIP router is the gateway. Not ideal, but works for now. I'd like to have the Belkin running as a router so that it's firewall services are available, but the VoIP router seems to have a a firewall and all the computers on the network are Macs or Linux systems, so they are already fairly secure on their own.

    One of the Linux machines dual boots (rarely) into Windows, so I'll have to be careful with that, but as I said the VoIP router looks to have a built in firewall of some sort as well, and the Windows boot runs some sort of software firewall as well (ZoneAlarm I think).

    Thanks for the reply though, nice to always be able to count on MR members to lend a hand!


Share This Page