Wake from sleep wifi issue iPhone 5

Discussion in 'iPhone' started by Trey M, Sep 22, 2012.

  1. macrumors 6502

    Joined:
    Jul 25, 2011
    Location:
    TX, USA
    #1
    So I've noticed everytime I leave my iphone 5 sleeping for a minute or so and then I press the home button to turn the screen on, LTE is the first default connection on the top left status bar. Then, after 2 seconds or so, the wifi indicator returns, confirming my connection to our router. Has anyone else noticed this? Is the iPhone 5, or maybe just the Verizon iPhone 5, defaulting to other technologies when in sleep mode, therefore causing background data (email, push, notifications) to use my cellular connection instead of wifi?
     
  2. macrumors 6502a

    Opstech

    Joined:
    Jan 5, 2010
    Location:
    California
    #2
    Mine is doing this too. I see no need to worry about it. My 4s did it too
     
  3. macrumors member

    Joined:
    Sep 21, 2012
    #3
    I am on ATT - mine does the same thing... shows LTE for a split second when waking it, then reverts to house wifi. I don't know if any cellular data is being consumed when asleep, but this doesn't affect me - unlimited user. However, I'd be interested to know why this is occurring.
     
  4. macrumors 6502

    Joined:
    Dec 25, 2008
    #4
    My 4 and 4S do the same thing, its normal. The wifi always shuts off after you put the phone to sleep and reconnects when woken up.
     
  5. thread starter macrumors 6502

    Joined:
    Jul 25, 2011
    Location:
    TX, USA
    #5
    I know for a fact my 4S didn't do this. Not saying y'alls didn't, but mine never had this issue. Regardless, the fact that you all have had this issue sort of makes it a non-issue.

    Still worries me that notifications are being pushed using cellular data. I just moved from AT&T unlimited to Verizon 6GB data plan so I definitely need to start watching my data!
     
  6. macrumors regular

    Joined:
    Feb 22, 2011
    #6
    My 4,4s and 5 do it. It's complete normal.

    I don't think it consumes data as when on vacation and in airplane mode and only connected to data it still gives me my notifications.
     
  7. macrumors 6502a

    EarthDawn

    Joined:
    Feb 18, 2008
    Location:
    Long-eye Land, NY
    #7
    Same thing ...

    My girlfriends 4s is on wifi all the time... but when I hit my home button its on 4G and then a couple seconds later kicks to wifi...
     
  8. macrumors 6502a

    Vundu

    Joined:
    Jun 10, 2009
    Location:
    Manchester, UK
    #8
    Your battery would suffer if it kept a constant wifi connection when asleep.
     
  9. macrumors 6502a

    Joined:
    Oct 30, 2011
    #9
    I don't think this is true. When I'm at home I always disable cellular data so that wifi stays on all the time. In my experience this drastically improves battery life. Last night I lost around 4% battery life in 8 hours whilst in standby with wifi connected and cellular data off.
     
  10. macrumors newbie

    Joined:
    Sep 21, 2012
    #10
    I know for a fact that your 4S did do this. This is standard behaviour and has been since the very first iPhone. All data whilst in sleep is sent via cellular as the wifi is powered down (unless using airplay etc).
     
  11. macrumors newbie

    Joined:
    Sep 24, 2012
    #11
    Wifi consumes less battery than LTE and additionally, if you have push notifications on those will use cellular data and use up data from whatever data plan you have. Seems like a big oversight to fallback to LTE here when wifi is available.
     
  12. macrumors member

    jkkool

    Joined:
    Aug 22, 2010
    #12
    I have same problem, mine is factory unlocked, the place where im is not even have 3G we are on EDGE, and the problem starts here when i put some big app on update or buy new app and when my phone goes to sleep it stops and when wake it up thinking that app must be downloaded it shows that unable to download app. sometime i have to keep it awake or i tried couple of times leaving it till it goes to sleep by itself then after pressing home button i see Wifi, today ill be checking it on my 4s, i never had this app update problem on 4s.
     
  13. macrumors regular

    Joined:
    Sep 18, 2012
  14. thread starter macrumors 6502

    Joined:
    Jul 25, 2011
    Location:
    TX, USA
    #14
    Looks like the latest iOS update has made this a non-issue. Even though I still see the quick change from LTE to wifi in the status bar, there is no 2 second delay, like before, for this to happen. With the update, it seems like a split second. I think the iPhone is communicating every so often with the router just to let it know its still there so that when a user turns on their device, their iPhone is instantly ready to begin consuming data on wifi. I think the update (6.0.2) has really just made wifi a lot more efficient overall. :cool:
     

Share This Page