Was a fix ever found for shutting off speakers when using headphones on G5 PMs?

Discussion in 'PowerPC Macs' started by NIPRING, Feb 24, 2010.

  1. macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Waukesha WI
    #1
    Its been a while since i've looked into this after i first realized that the speakers attached to my G5 PM didnt shut off when i plugged in headphones. Has there ever been any type of software fix for this? And while we're at it, was this issue resolved in Mac Pros?
     
  2. macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #2
    Don't know but this is also something that I too wondered about since I have it hooked up to my TV/monitor. I have to mute my monitor if I plug my headphones into my G5.
     
  3. thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Waukesha WI
    #3
    I know. Its not a serious issue, just an inconveince i had hoped was rectified by now.
     
  4. macrumors 6502

    Joined:
    Jun 29, 2008
  5. thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Waukesha WI
    #5
    Well, i downloaded it and fooled around a bit but I'm not seeing and distinction between output volumes. As soon as i slide the output volume down the headphone volume goes down as well as the desktop speakers. And the system volume seems to do nothing.
     
  6. macrumors 6502

    Joined:
    Jun 29, 2008
    #6
    Not sure how it behaves on G5's. It works great on my 2008 Mac Pro. Plug in headphones, speakers shut off, and vice versa. (I think there's a checkable menu item to enable that.)

    And by speakers, I mean external speakers I have plugged in to the analog out jack in the back.

    IIRC, it also remembers the headphone volume level between reboots.
     
  7. macrumors 68000

    4JNA

    Joined:
    Feb 8, 2006
    Location:
    looking for trash files
    #7
    on my dual 1.8, i never found a fix (software) up to around mid 10.4 when i had to sell it.

    that said, i went for a hardware fix by using logitech speakers with a remote volume control that had a headphone jack on it. that is, the volume control was a seperate device that controlled the speakers, but also had a headphone out jack that muted the speakers when headphones were plugged in. i set the g5 volume out to max, and used the logitech control for volume. many late nights of quake 4 spent this way...

    g5 sound (analog) out > logitech volume control > headphones. worked great!

    best of luck.
     

Share This Page