WD My Book Home Edition questions

Discussion in 'Buying Tips and Advice' started by Mr_Brightside_@, Mar 14, 2008.

  1. macrumors 65832


    Sep 23, 2005
    below Ash Tree Lane
    Hi, I'm looking at buying the WD My Book 500GB edition; the only thing I'm leery about is that it requires min. 10.4.8, which not all my Macs have (or need...). Does anyone have this drive working with 10.3.x, or anyone who might be able to test if it does work? Cheers.
    Edit- Great, thank you very much. I thought it was like that; just wanted to be sure. Cheers again
  2. macrumors 68020


    Mar 14, 2004
    Chicago, IL
    The OS requirement is not for being able to use the drive but for being able to use the software and driver (to enable the Capacity Gauge) that ship with it.

    If you system doesn't meet the minimum system requirements (but is at leas OS 9 or any OS X) it will just work as a normal external hard drive and the capacity gauge won't work. That is about all.

Share This Page