Weak Wifi Signal iPhone 5

Discussion in 'iPhone' started by ruckleapple, Sep 21, 2012.

  1. ruckleapple macrumors member

    Joined:
    Sep 13, 2012
    Location:
    Japan
    #1
    OK, first iPhone 5 problem.
    I've logged into the wifi at my house and my iPhone has accepted it but if I walk 3 meters away from the router the signal bars drop down from full to nothing and LTE comes back on. While my iPhone 4 still has wifi signal with full bars.

    Any ideas?
     
  2. Stibbzy macrumors newbie

    Joined:
    Sep 21, 2012
    #2
    I have exactly the same issue. It connects at very short range but drops off after a few meters. I have tried resetting the wireless settings, resetting all network settings and finally wiped everything and started again. Still no luck :(
     
  3. TheMagicPirate macrumors newbie

    Joined:
    Sep 20, 2012
    #3
    I can't comment on my home wifi but my iPhone 5 is on my works wifi and the range seems fine, although I can't comfirm where the wifi originates from.
     
  4. HowardSmith macrumors 6502a

    Joined:
    Sep 13, 2012
    #4
    My office WiFi network is working just as good as the iPhone 4S.
     
  5. ruckleapple thread starter macrumors member

    Joined:
    Sep 13, 2012
    Location:
    Japan
    #5
    I've tried all that too. Still no luck. If I hold the phone next to the router I get full bars of Wifi. I walk away 2.5 meters and they vanish.

    This sucks.
     
  6. Powrie macrumors 6502

    Joined:
    Sep 14, 2012
    #6
    Something might be wrong with your Phones Wifi antenna.

    Or its not compatible with your Wifi base station.


    To test this, go get on some other Wifi.

    See if it still does this with other Wifi stations.
     
  7. Olivia23 macrumors 6502a

    Olivia23

    Joined:
    Jul 26, 2008
    Location:
    around
    #7
    Good thing I'm keeping my unlimited plan so I don't have to worry about wifi.
     
  8. AndrewI macrumors newbie

    Joined:
    Oct 17, 2011
  9. macguy360 macrumors 6502a

    Joined:
    Feb 23, 2011
    #9
    I am having opposite situation. Wifi range is much better than iphone 4s. I am picking up wifi signals that are way further out than with my old phone.
     
  10. motty2307 macrumors regular

    Joined:
    Feb 1, 2010
    #10
    Is it possible that the phone is automatically switching to the stronger signal?

    I'm not sure about this and don't know, it's just a guess.
     
  11. infinityharry macrumors member

    infinityharry

    Joined:
    Oct 29, 2010
    Location:
    UK - Cheshire
    #11
    yep im getting this problem to changed channels on the routers still no luck, hopefully apple figure it out
     
  12. Vundu macrumors 65816

    Vundu

    Joined:
    Jun 10, 2009
    Location:
    Manchester, UK
  13. AndrewI macrumors newbie

    Joined:
    Oct 17, 2011
    #13
    Any chance the few of us who are having the same problem also have guest networks with hidden SSID running? Or just guest networks?
     
  14. gforce216 macrumors 6502

    Joined:
    Jun 17, 2009
    #14
    Could it possibly be that the phone is connecting on the 5ghz band which produces a weaker penetration signal? Check your router settings to see if you have a 5ghz band active.
     
  15. Chad McCan macrumors newbie

    Chad McCan

    Joined:
    Feb 24, 2012
    Location:
    Kansas City, MO
    #15
  16. nfl46 macrumors 603

    nfl46

    Joined:
    Oct 5, 2008
    #16
    Same issue here as well. I have my Gnex side by side with my iPhone 5 and my iPhone 5 is crawling on wifi compared to my Gnex.
     
  17. AndrewI macrumors newbie

    Joined:
    Oct 17, 2011
    #17
    I dont have a 5GHz router. My neighbor does, but I'm not connecting to his network...

    ----------

    BTW, I have a iPhone 4s that has been updated to iOS6 and I don't have wifi problems with it.

    I am on the phone with Apple support now.
     
  18. Chad McCan macrumors newbie

    Chad McCan

    Joined:
    Feb 24, 2012
    Location:
    Kansas City, MO
    #18
    It's not a 5ghz or 2.4 ghz problem. It's an antenna issue. Within 1ft of the access point, network speed is great. 10 ft from the AP and you have no signal.

    I'm in the same room as my AP and I have no signal. It's not being blocked. My 4s has full signal.

    I'm tried my Airport Express, Airport Extreme and Time Capsule. All have the same problem.

    Bluetooth has the same problem. I have a genius bar appt tomorrow, but I probably won't wait that long to smash this hunk of ****.
     
  19. thenamesbryce macrumors newbie

    Joined:
    Oct 4, 2010
    #19
    I was wondering the same thing. They should turn off the cellular and keep wifi on. Then see if the wifi stays on at a further distance away.
     
  20. AndrewI macrumors newbie

    Joined:
    Oct 17, 2011
    #20
    I tried turning off cellular data, that did not work.
    I tried changing router wireless channel. Did not work.
    I tried disabling LTE. Did not work.
    I rebooted router. Did not work.

    After being on the phone with their tier 2 tech support, he told me that I tried everything and the only thing left to do is to erase all data and completely reset the phone. Set it up as new phone. Not sign into any accounts and not restore. Try WiFi and then call him back. Trying that now. Will report back.
     
  21. wacky4alanis macrumors 6502

    Joined:
    Mar 18, 2009
    #21
    Sounds to me like the antenna is not connected properly.
     
  22. motty2307 macrumors regular

    Joined:
    Feb 1, 2010
    #22
    My second guess is that you may be holding it wrong :rolleyes:
     
  23. RyanTheGeneral macrumors regular

    Joined:
    Sep 10, 2009
    #23
    mine stays connected from good distance. but on speed test the 4s actually beats it
     
  24. ap105 macrumors regular

    Joined:
    Mar 17, 2011
    #24
    Had the same issue. Went to apple store and they exchanged it. Now wifi works!
     
  25. Ben C. macrumors member

    Ben C.

    Joined:
    Jun 14, 2009
    Location:
    New England
    #25
    My Wi-Fi signal is actually stronger with the 5...
     

Share This Page