Web sharing with router

Discussion in 'Macintosh Computers' started by lucarelli, Dec 2, 2003.

  1. lucarelli macrumors newbie

    lucarelli

    Joined:
    Oct 26, 2003
    Location:
    Montreal, Canada
    #1
    I have alot of problems getting personal web sharing to work through a Linksys router. Before I had no problems when I connect the cable modem directly. I have a dynamic IP with DDNS linking it to my ULR. I've set up my router so that it automatically forwards port 81(My ISP blocks hosting 80) I also DMZ (DeMilitarized Zone) the port. The router also forwords my IP to DNS.org . But still can' t access my website. I shows index.html page on LAN but not on WAN.
    How can I get an outside access point with a router.
     
  2. tomf87 macrumors 65816

    tomf87

    Joined:
    Sep 10, 2003
    #2
    For starters, I would not set your machine to be in a DMZ. That's a high security risk.

    On my Linksys, I hit the Advanced tab, then the Forwarding tab. Click the UPNP forwarding button, and add your IP on the internal side on a new row, give it a name and the port TCP 81. Click enable and then save.

    Also, keep in mind that everyone won't be able to browse your site via http://www.yourdomain.com. They will need to use http://www.yourdomain.com:81.
     
  3. ibookin' macrumors 65816

    ibookin'

    Joined:
    Jul 7, 2002
    Location:
    Los Angeles, CA
    #3
    Is the web server you're using (I'm assuming Apache) configured to run on port 81? Either that or you could forward external port 81 to internal port 80, which can be accomplished in the UPnP forwarding section.

    To configure Apache for port 81:

    1. Open a terminal window
    2. Type "sudo vi /etc/httpd/httpd.conf"
    3. When prompted, enter your admin password
    4. Scroll down to this section
    5. Change it so it reads this:
    6. Type <esc>":wq" then press enter
    7. Restart Apache by turning off Personal Web Sharing and turning it back on

    NOTE: I have not tried this on my own machine, so I am not 100% sure it will work. Would someone please verify this before the original poster tries it?
     
  4. lucarelli thread starter macrumors newbie

    lucarelli

    Joined:
    Oct 26, 2003
    Location:
    Montreal, Canada
    #4
    I already had set up Apache with the port change. I works just fine without router. As for the router port forwarding I played with it before but there was no luck. I will try today after work tomf87's way of forwarding using UPNP.
     
  5. lucarelli thread starter macrumors newbie

    lucarelli

    Joined:
    Oct 26, 2003
    Location:
    Montreal, Canada
    #5
    I forward the port 81 in UPNP but still no luck at all. I need serious help been working on this all week long.
     
  6. walibi macrumors newbie

    Joined:
    Mar 21, 2004
    Location:
    Montréal, Canada
    #6
    Had the same problem

    I had the same problem. went to advanced-fowarding ext-port 80 to 90 TCP UDP on my internal address but no luck. I added the UPnP Ext-port 81 on TCP to Int-port 80 to same internal address and it WORKED! after that i tried to enable on the same panel, HTTP Ext-port 80 TCP Int.port 80/81 on internal address and it had no effect, it still worked. You might try calling me, i'd give you a hand :p.
     

Share This Page