Web videos (YouTube and such) on the MBA are terrible.

Discussion in 'MacBook Air' started by duvinclunk, Jun 4, 2010.

  1. macrumors newbie

    Joined:
    May 4, 2010
    #1
    Yeah I know the processor is not that fast and it's not meant to be a super quick computer but I do watch lots of videos and they are just terrible on the MBA. It's like I can't get through 3 minutes of video before the sound and video start to skip up and get choppy. It's quite irritating. Wished there was something I could do...
     
  2. macrumors 68000

    Drag'nGT

    Joined:
    Sep 20, 2008
    Location:
    Holly Springs, NC
    #2
    My Rev A runs HD video off youtube fine. Can you give us an example of a video that you're wanting to watch?

    Have you opted to watch video off youtube using html5 instead of flash?
     
  3. macrumors regular

    Joined:
    Aug 31, 2009
    #3
    My Rev B 128 SSD MBA has no problems, stutters, or choppiness with video/audio on the web. However, the fans do kick in depending on the format (Flash, etc.) and how many apps I have running simultaneously. My WiFi connection is pretty decent as well, which helps with any sort of streaming content.
     
  4. macrumors 6502

    Joined:
    May 12, 2010
    #4
    Wirelessly posted (Mozilla/4.0 (compatible; MSIE 6.0; Windows CE; IEMobile 7.11) Sprint PPC6850SP)

    I've discovered a web site that it seems the Air, and Macs in general, can't hangle. www.salomon.com Maker of travel bags and sporting goods. The Apple store salesman said "This appears to be a site that was not made to work well on Macs." Huh? That's an upside-down and backwards way of saying it. ---- We tried it on the Air, then on a 15" pro. He first tested if it was just a browser limitation, by downloading Firefox. Same difficulties on both browsers. "It just works." ? If only.
     
  5. macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #5
    Do me a favor. Post a couple of links of videos that you have no issues with.

    Mine has always stuttered as well, and I would like a comparison. I do have the new 10.1 plugin, so it has been better.

    thx
     
  6. macrumors 601

    Scottsdale

    Joined:
    Sep 19, 2008
    Location:
    U.S.A.
    #6
    Assuming you have a v 2,1 MBA... things will get better very quickly.

    OP, assuming you have a v 2,1 MBA with Nvidia 9400m GPU, read the following. If you have the Intel GMA, in an original MBA, get a hammer!

    The problem is NOT the fact that it's a MacBook Air. The CPU and GPU are plenty capable with Penryn CPU and Nvidia 9400m GPU. Your problem is you're using OS X which is terribly inferior to Windows for graphics, OpenGL, HD videos, Flash, and etc. Apple had not allowed any low-level access to APIs needed for h.264 acceleration (uses your GPU for graphics - imagine that) until a month ago. With h.264, OS X should get better at graphics work, but it's still with inferior OpenGL and the graphics drivers Apple writes for the GPUs it uses.

    Anyone can prove to themselves that the MBA has capable hardware if they just BootCamp into Windows 7 to watch the same videos, Flash, and etc play perfectly. In Windows, about 1/4 of the CPU is being used as the GPU handles all of the h.264 acceleration.

    Blame Apple for its terrible drivers, lack of willingness to worry about its users' experiences for graphics, and for not working with third party software vendors to provide a graphics experience similar to what's available with the exact same hardware in Windows. Most hardware vendors write their own drivers for Windows. Apple writes its own drivers which is a gigantic part of the problem. It seems that Apple writes graphics drivers terrible poorly. Maybe it's going for "stability"? I don't know why they cannot get it done. And Apple writes so few drivers since it only uses a few GPUs across all of its Macs.

    Around 2 GHz is what's needed for HD playback for a CPU; quite a few HD playback apps list 2 GHz as minimum CPU required, and iTunes is one of them that lists 2 GHz CPU for HD playback. All other Macs have CPUs that aren't throttled, so they have fewer problems (but it doesn't eliminate the problem of the GPU not doing the work instead of the CPU). However, they use about 4X the CPU for HD videos, Flash, and etc as does the same hardware in Windows. So if the CPU is being used for other processes, the graphics will struggle. When h.264 GPU acceleration is available, the majority of the h.264 graphics work is handled by the GPU. This means the CPU is available for other tasks and the computer will run much better when handling graphics.

    Fortunately Apple just sorta changed course and gave API h.264 acceleration access to third party developers. In the future, applications will better take advantage of h.264 acceleration. Since the GPU will be handling h.264 with HD video playback, Flash, and etc, the CPU will be available for other tasks and the user's experience will improve dramatically.

    You can start improving your OS X graphics experience by upgrading all of your graphics software (Flash and HD video playback apps) to newer versions that utilize the h.264 acceleration APIs. Flash and HD video playback apps are upgrading their software and they will rapidly improve your video playback on the MBA. Of course the alternative is to just bootcamp into Windows 7 and enjoy an incredible system that blows away OS X in graphics-based tasks. The blame here should never be the MBA. The blame should be on Apple for not providing the best experience to its Mac OS X users. The "mighty" OS X isn't so mighty when it comes to graphics performance.

    One last thing. Apple only provides h.264 GPU hardware acceleration on three GPUs - 9400m, 320m, 330m GT. Any other Mac is using the CPU instead of the GPU for h.264 acceleration. This is why Nvidia's GPUs are so very important to Apple's Macs. This is also why Apple uses one GPU across five Macs, as it can create one set of drivers, OpenCL, h.264, and etc. for every Mac that uses the Nvidia 320m/9400m. The 330m GT is doing the h.264 because the Intel GMA is just about worthless while the Nvidia GPUs are made for these tasks. And this is why everyone that cares about graphics, watching HD videos, Flash, and etc needs a v 2,1 MBA as the original MBA isn't capable...
     
  7. macrumors 68000

    Drag'nGT

    Joined:
    Sep 20, 2008
    Location:
    Holly Springs, NC
    #7
    I was on my iMac and tried this site. I have to say it did take around 5 sec to finish loading the flash properly so I could use it. Basically the site loaded quickly and then I had to wait 5 sec for the flash elements in the words on the left of the screen to recognize my cursor and behave properly. After that though the site worked fine. No broken links or stuck pages. What were you doing that "didn't work"?
     
  8. macrumors newbie

    Joined:
    Jun 18, 2009
    #8
    I must agree here. I have this unit as well (Rev B 128 SSD MBA). Pretty happy 90+% of the time. It does get pretty warm, but not a lot of stutter. The original Rev A 80Gb HDD I had was horrible(!) in this regard......
     
  9. macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #9
    I have the same experience. 0% problems on the Solomon site despite the fact that I am traveling, and using my MBA (rev C /SSD) using an anemic Verizon MiFi 3G connection.

    /Jim
     
  10. macrumors 68000

    gwsat

    Joined:
    Apr 12, 2008
    Location:
    Tulsa
    #10
    The page seemed to load about as quickly on my Santa Rosa MBP as any other containing a large graphic image. Maybe that was because I am accustomed to Web pages loading more slowly on my older NBP than some of the rest of you who have newer machines experience. In the interest of science, I loaded the same page in Internet Explorer on my Windows 7 virtual machine and it seemed to load about as fast as it had with Chrome running under OS X. Anyway, the graphic with the path in the foreground and the glacier in the background is pretty spectacular.
     
  11. macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #11
    It's simple: the Flash plugin for Mac sucks. Steve Jobs has pointed it out plenty of times. It's a very big handicap imposed on Macs because of shoddy coding on Adobe's part.

    Most web video is delivered through the Flash plugin currently; but that is changing. When Flash starts to be less commonplace, you'll see a marked improvement.
     
  12. macrumors regular

    Joined:
    Aug 31, 2009
    #12
    Maybe it would be easier if you could post some links of videos that do stutter for you? Since I haven't noticed any problems with mine, I'm not sure where to begin for a fair comparison.
     
  13. wol
    macrumors member

    Joined:
    Jun 15, 2005
    #13
    ClickToFlash

    Check out ClickToFlash - plays high quality videos on YouTube in QuickTime, not Flash, with considerably reduced CPU usage.
     
  14. macrumors regular

    Joined:
    Aug 31, 2009
    #14
    I just visited that site, and had no problems viewing it. In fact, it loaded noticeably faster than the MacRumors homepage.
     
  15. macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #15
    Good idea,

    Heres one that stutters on mine. Legend
     
  16. macrumors 6502

    Joined:
    May 12, 2010
    #16
    Wirelessly posted (Mozilla/4.0 (compatible; MSIE 6.0; Windows CE; IEMobile 7.11) Sprint PPC6850SP)

    Examples of trouble making YouTube videos on Macs: Several of Yongfook's home videos have audio WAY out of synch with the video. He has 2 or 3 videos discussing his then-new Macbook Air, so those are apparently made on his Macbook Pro. (One's easily 2 or 3 seconds out of synch.) I'm not sure if any videos after that, were made on the 'Air'.
     
  17. macrumors member

    Joined:
    Oct 26, 2007
    #17
  18. macrumors regular

    Joined:
    Jul 5, 2008
    #18
    It's not that simple. Situation is much closer to what Scottsdale described above. It was not possible for Adobe to provide GPU based h264 acceleration on OSX until a few months ago when there was a change in OS update that allowed for it. Now they do offer a preliminary version of 10.1 plugin that does GPU accelerated video playback in Flash, but that only works with Nvidia GPUs, so the Rev A owners are screwed as usual.
     
  19. thread starter macrumors newbie

    Joined:
    May 4, 2010
  20. macrumors newbie

    Joined:
    Jun 18, 2009
    #20
  21. macrumors 601

    Scottsdale

    Joined:
    Sep 19, 2008
    Location:
    U.S.A.
    #21
    Install Windows 7 and you'll never have that problem again.

    Did you read my post? Do you have a v 2,1 MBA or the original? If it's the 2,1, there is light at the end of the tunnel. If it's a 2,1, you need to update your software plugins. If it's an original, install Windows and it just might eliminate those problems too. This is a problem with OS X itself and not the MBA.
     
  22. thread starter macrumors newbie

    Joined:
    May 4, 2010
    #22
    I have the new and latest, as of now. I bought it less than a month ago, top of the line...
     
  23. macrumors regular

    Joined:
    Aug 31, 2009
    #23
    I didn't really notice any problems with this one, although the fans kicked in about 2 to 3 minutes into the video. I only watched for about 6 to 7 minutes though. There was a very slight delay at 2 spots which I attributed to the streaming more than anything else.



    This one though, definitely stuttered, and was not really watchable. I don't have the beta version of the Flash though, so I'm not sure if that would help. I also haven't tried playing it while in Windows.

    One thing I'd like to point out is that I don't use my MBA as a portable media player. And while I've watched several "web videos", sometimes a couple hours at a time, none were full length HD movies/shows. Well, that's not entirely true since I do stream Netflix movies, and sometimes NBC shows.

    I've noticed a big difference in the range of quality of the different media players being used by various companies, which in turn affects the quality of the video stream being watched. I've also noticed a big difference with the quality of streaming depending on how good the internet/wifi connection is. I think both of those issues (along with proper drivers) play a much bigger role in what the MBA is capable of, than the actual hardware itself.
     
  24. macrumors 68000

    gwsat

    Joined:
    Apr 12, 2008
    Location:
    Tulsa
    #24
    I routinely watch Netflix streaming on my iPad and, except for occasional network glitches which are inevitable, Netflix has been fine on my iPad. The Netflix client on both of my TiVo DVRs is uniformly good, too. Has Netflix been stable and satisfactory on your MBA?

    I agree that the speed and stability of the network connection, both internal and Internet, and the drivers used, are all far more important than the hardware being used to watch streaming video. I have an 802.11n wireless network and a very fast high speed Internet connection through Cox OKC. Thus, streaming video is usually more than satisfactory, even on the iPad.
     
  25. macrumors 601

    Scottsdale

    Joined:
    Sep 19, 2008
    Location:
    U.S.A.
    #25

    I suppose it was a pointless waste of my time to write that then...
     

Share This Page