WebServer Experts, Please Put On Your "Good Citizen" Caps!

Discussion in 'Mac Apps and Mac App Store' started by totally_fly, Jul 10, 2004.

  1. totally_fly macrumors member

    Joined:
    Nov 12, 2002
    #1
    I'm in need of assistance. I have gone beyond the general use of built-in WebServers under 10.3 and modified my httpd.conf file to change things around and make me happier. Everything has been fine and dandy, including the modification of my DocumentRoot setting from the default to my ~/Sites/ directory. I need to change this DocumentRoot setting again (for reasons I don't consider relevant). I have two internal hard drives. I use one as my "Mac OS 10.3" hard drive and my other as my "Internal Storage" drive. The latter does not have an operating system installed. I use it to store mainly everything besides music and pictures (because my OS X drive easily has enough space for those). Unfortunately, what seemed like the obvious thing to do gave me unexpected results.

    I changed the DocumentRoot setting to "/Volumes/Storage/Sites/"
    I then did the customary "sudo apachectl graceful" (you guessed it: graceful restart)
    And then I went to see that everything was in order. I put a file in the new Sites directory that would not be in the old directory (just to make sure, you know) and it loaded... I was indeed looking at the new Sites directory. I don't need to hide my WebServer address, so here it is:
    http://achkara.ath.cx:82/

    (Yes, port 82. I have a nasty ISP that blocks port 80. This is not an issue because I properly circumvent the block.)

    As you might have discovered, my WebServer is not very friendly or welcoming. :p I use it as a private way to share files with friends and host images and such on forums.

    -Ok, I'm an expert here, I don't need to be wasting my time.. this guy's WebServer works fine.-

    If you're thinking something along those lines, now is when you need to listen up most. Every file in the intial directory of my WebServer is accessible. You're seeing index.html just fine. You could listen to http://achkara.ath.cx:82/Surprise.mp3 if you wanted to. However, any directory inside this directory is inaccessible.

    Try it. Go to: http://achkara.ath.cx:82/Flash/

    It won't work. You will see:

    I don't know why. What boggles me most is that you can see things in this directory, just not the directory listing.

    http://achkara.ath.cx:82/Flash/curveToMouse.swf
    or
    http://achkara.ath.cx:82/Flash/3curves.swf

    Maybe the solution is simple. I have done all I can by setting the privileges correctly with the Finder. I believe that my httpd.conf file remains unchanged besides the DocumentRoot string.

    If you know what I need to do, please be a good citizen and help me out. Thanks a lot!
     
  2. mrsoundman24 macrumors newbie

    Joined:
    Feb 4, 2004
  3. totally_fly thread starter macrumors member

    Joined:
    Nov 12, 2002

Share This Page