Website mini-icon...

Discussion in 'Mac Scene' started by Snowy_River, Jul 13, 2003.

  1. macrumors 68030

    Snowy_River

    Joined:
    Jul 17, 2002
    Location:
    Corvallis, OR
    #1
    Okay, I'm sure the answer to this question is a simple one, but I have yet to determine it in my general browsing.

    I'm webmaster of a couple of websites, and I am trying to find out how to get browsers to place a mini icon next to the address in the address bar (like MacRumors' Apple/Question Mark, of these forums' check box icon).

    So, without making me feel really stupid ;), could someone tell me what I need to do?

    Thanks a million!
     
  2. macrumors 68040

    Kwyjibo

    Joined:
    Nov 5, 2002
    #2
    I would do a search thre have been quite a few threads on it. If i knew a simple way to do it i would tell you but i know its here
     
  3. Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #3
    Search MacRumors for the word Favicon. That's what they are called.
     
  4. macrumors 6502a

    jbomber

    Joined:
    Jun 24, 2003
    Location:
    Brooklyn - NYC
    #4
    those things are called favicons. they're 16x16 windows .ico files. you can make them with a windows machine using the 256 color palette, or you can go to a UK site which will actually let you design your icon on there and they'll e-mail you the final.
     
  5. macrumors 6502a

    BaghdadBob

    Joined:
    Apr 13, 2003
    Location:
    Gorgeous, WA
    #5
    OK, I just did a search on OS X Downloads, VersionTracker, and CNET and no dice. WTF? Then I go to Google and the best I came up with was a five dollar plug in for PS.

    Someone...say...on these forums, perhaps, needs to amend this. This is a Mac travesty.
     
  6. macrumors 68040

    Kwyjibo

    Joined:
    Nov 5, 2002
  7. macrumors 68000

    e-coli

    Joined:
    Jul 27, 2002
    #7
    It's a .ico file. Just upload the .ico file to the root directory of your website. You can make them with IconBuilder Pro from Icon Factory
     
  8. thread starter macrumors 68030

    Snowy_River

    Joined:
    Jul 17, 2002
    Location:
    Corvallis, OR
    #8
    Thank you everyone, I found the info from other threads quite helpful. However, for some strange reason the favicon that I'm trying to set up as a test case appears while the page is loading, but then vanishes once loading is complete.

    That's in Safari. In Camino and IE it doesn't show up at all. I used the header link as defined in the MS page...

    [edit]
    Okay, I've got it working in Safari. I just had to delete the old Bookmark that had the wrong favicon associated with it. But that still doesn't explain two things:

    First, why isn't it working in IE or Camino?

    Second, why is it that so many of the web pages that I've looked at the source for which have favicons don't have the above link tag in the header (including MacRumors)? How are they managing to get their favicons?

    Anyone have any ideas on these?

    [/edit]

    [edit2]
    Okay, I've realized that IE doesn't support them. Still having problems with Camino, though.
    [/edit2]
     

Share This Page