Weird Airport Authentication Issue

Discussion in 'macOS' started by methodmano, May 23, 2005.

  1. methodmano macrumors member

    Aug 1, 2004
    For some reason, every time I open my iBook (10.4.1) up or it needs to reestablish a connection to my wireless network it asks for authentication. This just started happening yesterday. The authentication isn't the wireless network's but the log-in. I get a dialog box that says:

    Mac OS X requires that you type your password

    Requested right: (can't see the rest)

    Tool: airport

    If I click on the arrow next to airport I get:

    Anyone know why this suddenly happened and how I can get rid of the need to authenticate all the time? The only thing I can think of that would have affected this is that I installed PHP and MySQL, but that was a couple of days ago and this issue didn't show up until a couple days after that. Thanks for any help/advice.
  2. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Have you tried doing keychain first aid from Keychain Access (in your utilities folder)?
  3. andiwm2003 macrumors 601


    Mar 29, 2004
    Boston, MA

    since i switched to 10.4.1 my system.keychain behaves strange. it appears twice in keychain access and doesn't allow me to see the airport password.

    maybe you have a similar problem and the apps can't get the airport password from the keychain so they ask you for it every time. in my case everything seems to work. just i can't see the password.

    i don't know if one can move the system keychain to some other place and let tiger create a new one. but i'm going to try this next.

  4. methodmano thread starter macrumors member

    Aug 1, 2004
    I ran the keychain repair utility but it didn't find any problems. I also repaired permissions. Neither of these seemed to help. Any other ideas? It only happens with airport. Thanks.
  5. jabberwock2000 macrumors newbie

    Sep 18, 2005
    Help! I have the same prob. Anyone know how to sort this out?
  6. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    Trying going into the Network pane in System Preferences

    Configure your Airport and choose options. Then, instead of leaving it at 'automatically join', change the drop down to see the preferred networks. Delete the one that you're having trouble rejoining each time. Then turn the airport off and on and rejoin the network. That should create a new entry for your airport connection.
  7. jabberwock2000 macrumors newbie

    Sep 18, 2005
    Brilliant... thank you so much!

    I thought is was could have been something in that area and messed around in the automatically join/preffered networks prefs but never thought to delete. Worked like a charm... thanks.
  8. jabberwock2000 macrumors newbie

    Sep 18, 2005
  9. jabberwock2000 macrumors newbie

    Sep 18, 2005
    Ah.. seems like deleting the associated keychain entry has done the trick.

    edit: Actually, no it hasn't. Grrrrrrr :(
  10. jabberwock2000 macrumors newbie

    Sep 18, 2005

Share This Page