Weird glitch/bug

Discussion in 'macOS' started by jared_kipe, Feb 6, 2006.

  1. jared_kipe macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
    #1
    When I came home today and woke my computer, something strange happened.

    I had a few apps running (all apple stuff like ichat and safari), I clicked on the mail window to bring it to the front and everything but mail disappeared.

    What makes matters worse, every time I'd click on another app in the dock, that app would come up but all the other applications windows would disappear.

    Reboot fixed it, but it was very weird.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  3. jared_kipe thread starter macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
    #3
    Thats funny, I just slept and reawakened her to the same problem, and then I see what you say. So I hold option and click on a window and everything seems good now. Could it be the way I put it to sleep with cmd+opt+eject?
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    I dunno. So are you saying that your OPTION key seems toggled?
     
  5. jared_kipe thread starter macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
    #5
    If I hold option and click then the app I was just on disappears, and it seems that when I wake from sleep that is how it always is unless I hold option again.

    EDIT: Doesn't happen if I go to the apple menu to sleep the computer.
     
  6. VanNess macrumors 6502a

    VanNess

    Joined:
    Mar 31, 2005
    Location:
    California
    #6
    You may want to trake a trip to system preferences and select universal access, then select the keyboard tab. If "sticky keys" is set to on, set it to off.
     
  7. jared_kipe thread starter macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
  8. VanNess macrumors 6502a

    VanNess

    Joined:
    Mar 31, 2005
    Location:
    California
    #8
    You mean it's off and you're still having the problem?

    If so, the last software related thing I can think of (and it's a long shot) is to check the keyboard and mouse preference pane and see if the keyboard settings look normal. Maybe try a new, slightly altered setting for rate and repeat and see if the problem persists. You might also click the modifier keys tab (in the keyboard preference) and select restore defaults. I'm not aware of a plist file associated with keyboard settings, but I never monkeyed with them anyway. Whatever they were out of the box is the way they still are for me

    The other possibility is a hardware problem. You might try rebooting your computer (since that seems to eliminate the trouble) and try using the "other" option key if you are normally using just one. The other possibility is to get your hands on a known good keyboard and swap that with your keyboad and see if that solves it. Well, hopefully this isn't a laptop, lol.
     
  9. jared_kipe thread starter macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
    #9
    Its totally a bug, if I put the computer to sleep using the option+cmd+esc then when it wakes up its like the option is permanately on till I hit it.
     

Share This Page